hdu 2647拓扑排序

Problem Description
Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input
2 1
1 2
2 2
1 2
2 1

Sample Output
1777
-1

对于这样的问题,可以用拓扑排序来做,把’<’看成一条有向边,于是就可以得到一个有向图,于是只要使得每条边(u,v)的u在v前面就行了。
注:如果存在有向环则不存在拓扑排序。

#include<iostream>
#include<algorithm>
#include<numeric>
#include<vector>
#include<string>
#include<sstream>
#include<string>
#include<cstdio>
#include<math.h>
#include<cctype>
#include<queue>
#include<cstring>
#define INF 0x3FFFFFFF
using namespace std;
int deg[10010];//表示对于i有几个'<'关系
int val[10010];
vector<int> vc[10010];
bool toposort(int n){
    int t=0;
    queue<int>que;
    for(int i=0;i<n;++i){
        if(deg[i]==0)que.push(i);//把最小的先加进队列中
    }
    while(!que.empty() ){
        int v=que.front();que.pop();
        t++;
        //Ans[t++]=v+1;
        while (vc[v].size()) {
            int temp = vc[v].back();
            vc[v].pop_back();
            val[temp] = max(val[temp], val[v]+1);//表示temp所代表的人比v代表的人要的钱多
            deg[temp]--;
            if (deg[temp] == 0) {
                que.push(temp);
            }
        }
    }
    //cout<<t<<' ';
    if(t<n)return false;
    return true;
}
int main()
{
    int n,m;
    while (cin>>n>>m) {
        for (int i = 0; i<10010; i++) {
            vc[i].clear();
        }
        for (int i = 0; i<n; i++) {
            val[i] = 888;
        }
        memset(deg, 0, sizeof(deg));
        for (int i = 0; i<m; i++) {
            int x,y;
            cin>>x>>y;
            x--;y--;
            deg[x]++;//x要的钱比y多,所以deg[x]++
            vc[y].push_back(x);
        }
        long long ans = toposort(n);
        if (ans == 0) {
            cout<<-1<<endl;
        }
        else
        {
            ans = 0;
            for (int i = 0; i<n; i++) {
                ans += val[i];
            }
            cout<<ans<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值