素数筛选法2

Max Factor
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4782
Accepted: 1865

Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input

* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38

Hint

OUTPUT DETAILS:
19 is a prime factor of 38. No other input number has a larger prime factor.

Source

USACO 2005 October Bronze


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int prime[20000],num,is[21000];
int k=0;

void prm(int n)
{
  int i,j;
  int s;
  int e=(int)(sqrt(0.0+n)+1);
  memset(is,1,sizeof(is));
  prime[k++]=2;
  is[0]=is[1]=0;
  for(i=4;i<n;i+=2) is[i]=0;
  for(i=3;i<e;i+=2)
    {
      if(is[i]){
        prime[k++]=i;
        for(s=i*2,j=i*i;j<n;j+=s)
          {
            is[j]=0;
          }
      }
    }
  for(;i<n;i=i+2)
    if(is[i])
      prime[k++]=i;
}

int main()
{
  int a[5005];
  int m;
  int i;
  int n;
  int temp;
  prm(20000);
  int j;
  /* for(int i=0;i<=100;i++)
    {
      printf("%d ",prime[i]);
      }*/
  scanf("%d",&m);
  int mymin=0;

  for(i=1;i<=m;i++)
    {
      int kk;
      scanf("%d",&a[i]);
      n=a[i];
      for(j=0;prime[j]<=n;j++)
        {
          if(n%prime[j]==0)
            {
              kk=j;
            }
        }
        
      if(prime[kk]>mymin)
        {
          temp=i;
          mymin=prime[kk];
        }
    }
  printf("%d\n",a[temp]);
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值