HDU 3183 A Magic Lamp (RMQ)

5 篇文章 0 订阅

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4268    Accepted Submission(s): 1765


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source
 

题意:

给你一串数和m,删m个数,使删后的数最小。

POINT:

RMQ,每次找最小的数,注意查找的区间,要保证查找到的数后面还必须有数可以找(除非是最后一个)。注意一下这个即可。

第一次写RMQ,数组越界了好久。

for(int i=0;i+(1<<j)-1 < n;i++)

写成

for(int i=0;i<n;i++)

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
#define LL long long
const int  N  = 1200;
char s[N];
int m,n;
int dp[N][30];
int ans[N];
int Min(int a,int b)
{
    return s[a]>s[b]?b:a;
}
void preRMQ()
{
    for(int i=0;i<n;i++)
    {
        dp[i][0]=i;
    }
    for(int j=1;1<<j<n;j++)
    {
        for(int i=0;i+(1<<j)-1 < n;i++)
        {
            dp[i][j]=Min(dp[i][j-1],dp[i+(1<<j-1)][j-1]);
        }
    }
}
int query(int l,int r)
{
    int k=(int)log2((double)(r-l+1));
    return Min(dp[l][k],dp[r+1-(1<<k)][k]);
}

int main()
{
    while(cin>>s>>m)
    {
        n=strlen(s);
        memset(dp,0,sizeof dp);
        preRMQ();
        int now=0;
        memset(ans,0,sizeof ans);
        m=n-m;
        for(int i=m;i>0;i--)
        {
            int pos=query(now,n-i);
            ans[i]=s[pos]-'0';
            now=pos+1;
        }
        int i;
        for(i=m;i>0;i--)
        {
            if(ans[i]!=0)
                break;
        }
        if(i==0) printf("0");
        for(int j=i;j>0;j--)
        {
            printf("%d",ans[j]);
        }
        printf("\n");
    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值