HDU 1709 The Balance(母函数)

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8192    Accepted Submission(s): 3430


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
 

Source
 

题意:
给你几个砝码,一个天平,求出不能称出的重量,砝码可以左右放。

POINT:
母函数,其实感觉就是个DP而已。天平可以放两边就是减一下。

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <map>
using namespace std;
#define LL long long
const int N = 12000+6;
int c1[N],c2[N];
int a[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]),sum+=a[i];
        memset(c1,0,sizeof c1);
        c1[0]=c1[a[1]]=1;
        for(int i=2;i<=n;i++)
        {
            for(int j=sum;j>=0;j--)
            {
                if(c1[j]==1)
                {
                    c2[j]=1;
                    c2[j+a[i]]=1;
                    c2[abs(j-a[i])]=1;
                }
            }
            for(int j=0;j<=sum;j++) c1[j]=c2[j],c2[j]=0;
        }
        int cnt=0;
        int ans[N];
        for(int i=1;i<=sum;i++)
        {
            if(c1[i]==0)
            {
                ans[++cnt]=i;
            }
        }
        if(cnt==0) printf("0\n");
        else
        {
            printf("%d\n",cnt);
            for(int i=1;i<=cnt;i++)
            {
                if(!(i-1)) printf("%d",ans[i]);
                else printf(" %d",ans[i]);
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值