HDU 2864 Repository(字典树)

12 篇文章 0 订阅

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5619    Accepted Submission(s): 1867


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 

Source
 

题意:

找出给你的第2堆字符串是第1堆字符串的子串的个数。

POINT:

把第1堆字符串的从头到尾build一遍。注意重叠。比如abab

因为我每次用数组写,不会算到底要开多大。而且HDU数组越界总是报wa。

	if(sz>=N)
                while(1)
                {
                    printf("1");
                }
用这个来看看是不是数组开小了,是就会报 Output Limit Exceeded


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define  LL long long
const int N = 540000;
int tree[N][27];
int sz;
int pre[N];
int num[N];
void init()
{
    sz=0;
    memset(tree,0,sizeof tree);
    memset(pre,0,sizeof pre);
    memset(num,0,sizeof num);
}
void build(char s[],int x)
{
    int u=0;
    int l=strlen(s);
    for(int i=0;i<l;i++)
    {
        int j=s[i]-'a';
        if(tree[u][j]==0)
        {
            tree[u][j]=++sz;
            if(sz>=N)
                while(1)
                {
                    printf("1");
                }
        }
        u=tree[u][j];
        if(pre[u]!=x)
        {
            pre[u]=x;
            num[u]++;
        }
    }
}
int query(char s[])
{
    int u=0;
    int l=strlen(s);
    for(int i=0;i<l;i++)
    {
        int j=s[i]-'a';
        if(tree[u][j]==0)
        {
            return 0;
        }
        u=tree[u][j];
    }
    return num[u];
}
int main()
{
    init();
    int n;
    scanf("%d",&n);
    char s[22];
    for(int i=1;i<=n;i++)
    {
       // memset(s,0,sizeof s);
        scanf("%s",s);
        int l=strlen(s);
        for(int j=0;j<l;j++)
        {
            build(s+j,i);
        }
    }
    int q;
    scanf("%d",&q);
    while(q--)
    {
       // memset(s,0,sizeof s);
        scanf("%s",s);
        printf("%d\n",query(s));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值