Feel Good
Description
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life.
A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so. Input
The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10
6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input 6 3 1 6 4 5 2 Sample Output 60 3 5 Source |
题意:
找出一个区间,让区间内的最小值乘以(区间内数值总和)最大。
POINT:
思路是假设每个数都是区间最小,遍历每个数,找到左边和右边比他小的就停止扩张区间,得到答案,每次都和ans比较一下。
暴力寻找肯定超时,用单调栈优化。注意有数据为全是0的情况。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
using namespace std;
const int N = 100000+3;
#define LL long long
LL sum[N];
LL a[N];
int pos[N];
stack<int>q;
int main()
{
int n;
while(~scanf("%d",&n))
{
memset(sum,0,sizeof sum);
memset(pos,0,sizeof pos);
while(!q.empty())
q.pop();
LL ans=0;
int l,r;
for(int i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
pos[i]=i;
sum[i]=sum[i-1]+a[i];
while(!q.empty()&&a[i]<=a[q.top()])
{
int now=q.top();
LL nowans=(sum[i-1]-sum[pos[now]-1])*a[now];
if(ans<=nowans)
{
ans=nowans;
l=pos[now];
r=i-1;
}
pos[i]=pos[now];
q.pop();
}
q.push(i);
}
while(!q.empty())
{
int now=q.top();
LL nowans=(sum[n]-sum[pos[now]-1])*a[now];
if(ans<=nowans)
{
ans=nowans;
l=pos[now];
r=n;
}
q.pop();
}
printf("%lld\n%d %d\n",ans,l,r);
}
}