HDU 3374 String Problem(最小表达法+kmp)

10 篇文章 0 订阅

String Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3328    Accepted Submission(s): 1372


Problem Description
Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank  
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
 

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Sample Input
  
  
abcder aaaaaa ababab
 

Sample Output
  
  
1 1 6 1 1 6 1 6 1 3 2 3
 

Author
WhereIsHeroFrom
 

Source
 

题意:
给你一个字符串,让你求出字典序最小的同构字符串,并且求出有几个同样的。
同理在求最大的。

POINT:

最小表示法

http://blog.csdn.net/zy691357966/article/details/39854359

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int N =1000000+88;
int nxt[N];
void prenxt(char s[])
{
    int l=strlen(s);
    int i=0,j;
    j=nxt[0]=-1;
    while(i<l)
    {
        while(j!=-1&&s[j]!=s[i]) j=nxt[j];
        nxt[++i]=++j;
    }
}
int findmin(char s[])
{
    int i=0,j=1,k=0;
    int len=strlen(s);
    while(i<len&&j<len&&k<len)
    {
        int t=s[(i+k)%len]-s[(j+k)%len];
        if(t==0) k++;
        else
        {
            if(t>0) i+=k+1;
            else j+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i,j);
}
int findmax(char s[])
{
    int i=0,j=1,k=0;
    int len=strlen(s);
    while(i<len&&j<len&&k<len)
    {
        int t=s[(i+k)%len]-s[(j+k)%len];
        if(t==0) k++;
        else
        {
            if(t>0) j+=k+1;
            else i+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i,j);
}
char s[N];
int ans1,ans2;
int doit(int pos)
{
    int l=strlen(s);
    prenxt(s);
    int ans=1;
    if(l%(l-nxt[l])==0&&nxt[l]!=0)
        ans=l/(l-nxt[l]);
    return ans;
}
int main()
{
    while(~scanf("%s",s))
    {
        memset(nxt,0,sizeof nxt);
        int pos1=findmin(s);
        ans1=doit(pos1);
        int pos2=findmax(s);
        ans2=doit(pos2);
        printf("%d %d %d %d\n",pos1+1,ans1,pos2+1,ans2);
        
        
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值