HDU 1452 Happy 2004(约数和定理)

Happy 2004

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1904    Accepted Submission(s): 1394


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, in a separate line, please output the result of S modulo 29.
 

Sample Input
  
  
1 10000 0
 

Sample Output
  
  
6 10
 

Source
 

POINT:
了解一下约数和定理就行,用一下费马求逆元。

#include <iostream>
#include <stdio.h>
using namespace std;
#define  LL long long
const int p = 29;
int qkm(int base,int mi)
{
    base%=p;
    int ans=1;
    while(mi)
    {
        if(mi&1) (ans*=base)%=p;
        (base*=base)%=p;
        mi>>=1;
    }
    return ans;
}
int main()
{
    int x;
    while(~scanf("%d",&x)&&x)
    {
        int a=qkm(2,2*x+1)-1;
        int b=((qkm(3,x+1)-1)+p)%p*qkm(2,p-2);
        int c=((qkm(167,x+1)-1)+p)%p*qkm(166,p-2);
        printf("%d\n",a*b*c%p);
    }
    
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值