HDU 5974 A Simple Math Problem(GCD LCM)

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2801    Accepted Submission(s): 874


Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input
  
  
6 8 798 10780
 

Sample Output
  
  
No Solution 308 490
 

Source
 

题意:
给你a,b,让你求出x,y。满足(x+y)=a,LCM(x,y)=b。

POINT:
瞎搞,得出b*gcd(a,b)=x*y,再把x=y-a带入解方程。

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <map>
using namespace std;
const int maxn = 1000+44;
int gcd(int x,int y)
{
    if(x<y)
        swap(x,y);
    return y==0?x:gcd(y,x%y);
}
int main()
{
    int a,b;
    while(~scanf("%d %d",&a,&b))
    {
        int d=gcd(a,b);
        int A=1;
        int B=-a;
        int C=b*d;
        if(B*B-4*A*C*1.0<0){
            printf("No Solution\n");
            continue;
        }
        double y1=(-B+sqrt(B*B-4*A*C*1.0))/(2.0*A);
        double y2=(-B-sqrt(B*B-4*A*C*1.0))/(2.0*A);
        if(y1!=int(y1)){
            printf("No Solution\n");
            continue;
        }
        else
        {
            if(y1>y2)
                swap(y1,y2);
            printf("%.0lf %.0lf\n",y1,y2);
        }

    }

return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值