Quoit Design
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 56659 Accepted Submission(s): 15034
Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.
Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.
Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
Sample Input
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
Sample Output
0.71 0.00 0.75
Author
CHEN, Yue
Source
题意:
给你n个点,输出最近点距离的/2.
POINT:
分治,每次二分x坐标。求出两边的最近距离。
别漏了跨越两边的情况。
#include <string.h>
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
const int maxn = 100100;
struct node
{
double x,y;
}p[maxn];
int cnt[maxn];
double min(double a,double b)
{
return a<b?a:b;
}
bool cmd(node a,node b)
{
return a.x<b.x;
}
double dis(node a,node b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
bool cmd1(int a,int b){
return p[a].y<p[b].y;
}
double merge(int l,int r)
{
if(r-l==1){
return dis(p[l],p[r]);
}
if(r-l==2){
double a=dis(p[l],p[l+1]);
double b=dis(p[l],p[l+2]);
double c=dis(p[l+1],p[l+2]);
return min(a,min(b,c));
}
int mid=(l+r)>>1;
double ans=min(merge(l,mid),merge(mid+1,r));
int num=0;
for(int i=l;i<=r;i++){
if(p[i].x>=p[mid].x-ans&&p[i].x<=p[mid].x+ans)
cnt[++num]=i;
}
sort(cnt+1,cnt+1+num,cmd1);
for(int i=1;i<=num;i++){
for(int j=i+1;j<=num;j++){
if(p[cnt[j]].y-p[cnt[i]].y>=ans){
break;
}
ans=min(ans,dis(p[cnt[i]],p[cnt[j]]));
}
}
return ans;
}
int main()
{
int n;
while(scanf("%d",&n)&&n){
for(int i=1;i<=n;i++) scanf("%lf %lf",&p[i].x,&p[i].y);
sort(p+1,p+1+n,cmd);
double ans=merge(1,n);
printf("%.2lf\n",ans/2);
}
}