L2-012. 关于堆的判断 (最小堆)

L2-012. 关于堆的判断

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

上浮法。


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
#define LL long long
#define lt x<<1
#define rt x<<1|1
const int maxn = 1e3+111;
const int inf = 0x3f3f3f3f;
int n,m;
int a[maxn];
void build(int x)
{
	while(x/2>=1){
		if(a[x]<a[x/2]) {
			swap(a[x], a[x/2]);
			x=x/2;
		}
		else break;
	}
}
int f(int x)
{
	for(int i=1;i<=n;i++)
		if(a[i]==x) return i;
	return -1;
}
int main()
{
	scanf("%d %d",&n,&m);
	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
	for(int i=1;i<=n;i++){
		build(i);
	}
	string s;
	for(int i=1;i<=m;i++){
		int x;scanf("%d",&x);
		x=f(x);cin>>s;
		if(s=="and"){//x和y是兄弟结点;
			int y;scanf("%d",&y);
			cin>>s>>s;
			y=f(y);
			if(x/2==y/2&&x!=y){
				printf("T\n");
			}else
				printf("F\n");

		}else{
			cin>>s;
			if(s=="a"){//x是y的一个子结点。
				cin>>s;
				cin>>s;
				int y;scanf("%d",&y);y=f(y);
				if(x/2==y){
					printf("T\n");
				}else
					printf("F\n");
			}else{
				cin>>s;
				if(s=="root"){//x是根结点;
					if(x==1) printf("T\n");
					else printf("F\n");
				}else{//x是y的父结点;
					cin>>s;
					int y;scanf("%d",&y); y=f(y);
					if(y/2==x) printf("T\n");
					else printf("F\n");

				}
			}
		}

	}


	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值