L2-022. 重排链表

L2-022. 重排链表

时间限制
500 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一个单链表 L1→L2→...→Ln-1→Ln,请编写程序将链表重新排列为 Ln→L1→Ln-1→L2→...。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (<= 105)。结点的地址是5位非负整数,NULL地址用-1表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址;Data是该结点保存的数据,为不超过105的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:

对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:
00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
输出样例:
68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <set>
using namespace std;
#define LL long long
#define lt x<<1
#define rt x<<1|1
const int maxn = 2e5+111;
const int inf = 0x3f3f3f3f;
struct node
{
	int now;
	int val;
	int nxt;
}a[maxn],b[maxn],ans[maxn];
int main()
{
	int start,n;
	scanf("%d %d",&start,&n);
	for(int i=1;i<=n;i++){
		int address,data,nxt;
		scanf("%d %d %d",&address,&data,&nxt);
		b[address].val=data;
		b[address].nxt=nxt;
		b[address].now=address;
	}
	int cnt=0;
	int now = start;
	while(now!=-1){
		a[++cnt]=b[now];
		now=b[now].nxt;
	}
	int r=cnt,l=1;
	cnt=0;
	int temp=1;
	while(l<=r){
		if(temp){
			ans[++cnt]=a[r];
			r--;
		}else{
			ans[++cnt]=a[l];
			l++;
		}
		temp^=1;
	}
	for(int i=1;i<=cnt;i++){
		if(i!=cnt)
			printf("%05d %d %05d\n",ans[i].now,ans[i].val,ans[i+1].now);
		else
			printf("%05d %d -1\n",ans[i].now,ans[i].val);
	}


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值