POJ 2823 Sliding Window

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 53791 Accepted: 15431
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意:题目意思差不多都可以看懂,就是给出一串数字,从左到右每次遍历m个连续的数字,分别求m个连续的数字中的最小值和最大值。最小值和最大值分别在不同行输出。

分析:一开始是想用单调队列做的,奈何不是很懂单调队列的运用,后来看到给定了区间,求最大最小值,这个不是满足线段树的基本条件么?(真是神奇)于是就用线段树来做了,学过线段树的基本都会明白这就是一个裸的线段树了,具体看代码。

用C++提交,G++莫名的超时了~

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cstring>
#include<cmath>
#define lson l,m,id<<1
#define rson m+1,r,id<<1|1
using namespace std;
int MAX[4000000];
int MIN[4000000];
int ans1;
int ans2;
int min_[4000000];
int max_[4000000];
void pushup(int id)
{
    MAX[id]=max(MAX[id<<1],MAX[id<<1|1]);
    MIN[id]=min(MIN[id<<1],MIN[id<<1|1]);
}
void build(int l,int r,int id)
{
    if(l==r)
    {
        int temp;
        scanf("%d",&temp);
        MAX[id]=temp;
        MIN[id]=temp;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(id);
}
void solve(int a,int b,int l,int r,int id)
{
    if(a<=l&&r<=b)
    {
        ans1=max(ans1,MAX[id]);
        ans2=min(ans2,MIN[id]);
        return ;
    }
    int m=(l+r)>>1;
    if(m>=a)
        solve(a,b,lson);
    if(b>m)
        solve(a,b,rson);
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,n,1);
        for(int i=1;i<=n-m+1;i++)
        {
            ans1=-0x3f3f3f3f;
            ans2=0x3f3f3f3f;
            solve(i,i+m-1,1,n,1);
            min_[i]=ans2;
            max_[i]=ans1;
        }
        for(int i=1;i<=n-m+1;i++)
        {
            printf(i==n-m+1?"%d\n":"%d ",min_[i]);
        }
        for(int i=1;i<=n-m+1;i++)
        {
            printf(i==n-m+1?"%d\n":"%d ",max_[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值