POJ 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20508 Accepted: 10679

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source


题意:在一个串S中,寻找既是前缀又是后缀的子串,从小到大输出串的长度。这道题又让我知道了next数组的神奇~~

分析:我们知道next[len]=k表示长度为len时,最长相同真前后缀的长度是k,也就是说此时存在长度是k的既是前缀又是后缀的子串,这个说法我们又可以推出S[0~k-1]是这个子串,然后我们可以发现,在S[0~k-1]这个子串中,有符合条件的最长前缀和最长后缀,那么我们可以继续在这个子串中寻找更小的符合条件的子串,就是寻找next[k],直到next[k]=0,表示不存在 最长相同真前后缀。另外,串S可以是S本身的前后缀。

代码:
#include<cstring>
#include<cstdio>
using namespace std;

char str[400005];
int len;
int next_[400005];
int ans[400005];

void get_next(){
    len=strlen(str);
    int i=0,j=-1;
    next_[0]=-1;
    while(i<len){
        if(j==-1||str[i]==str[j]){
            i++;
            j++;
            next_[i]=j;
        }
        else{
            j=next_[j];
        }
    }
}

int main(){
    while(~scanf("%s",str)){
        get_next();
        int k=0;
        for(int i=len;next_[i]!=0;i=next_[i]){
            ans[k++]=next_[i];
        }
        for(int i=k-1;i>=0;i--){
            printf("%d ",ans[i]);
        }
        printf("%d\n",len);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值