Next Mayor--SOJ

One of the oddest traditions of the town of Gameston may be that even the town mayor of the next term is chosen according to the result of a game. When the expiration of the term of the mayor approaches, at least three candidates, including the mayor of the time, play a game of pebbles, and the winner will be the next mayor.

The rule of the game of pebbles is as follows. In what follows, n is the number of participating candidates.

Requisites
A round table, a bowl, and plenty of pebbles.
Start of the Game
A number of pebbles are put into the bowl; the number is decided by the Administration Commission using some secret stochastic process. All the candidates, numbered from 0 to   n-1 sit around the round table, in a counterclockwise order. Initially, the bowl is handed to the serving mayor at the time, who is numbered 0.
Game Steps
When a candidate is handed the bowl and if any pebbles are in it, one pebble is taken out of the bowl and is kept, together with those already at hand, if any. If no pebbles are left in the bowl, the candidate puts all the kept pebbles, if any, into the bowl. Then, in either case, the bowl is handed to the next candidate to the right.  (在任何一种情况下,碗被递交给右边的下一个候选人)This step is repeated until the winner is decided.
End of the Game
When a candidate takes the last pebble in the bowl, and no other candidates keep any pebbles, the game ends and that candidate with all the pebbles is the winner.

 

A math teacher of Gameston High, through his analysis, concluded that this game will always end within a finite number of steps, although the number of required steps can be very large.

Input

The input is a sequence of datasets. Each dataset is a line containing two integers n and p separated by a single space. The integern is the number of the candidates including the current mayor, and the integer p is the total number of the pebbles initially put in the bowl. You may assume 3 ≤ n ≤ 50 and 2 ≤ p ≤ 50.

With the settings given in the input datasets, the game will end within 1000000 (one million) steps.

The end of the input is indicated by a line containing two zeros separated by a single space.

Output

The output should be composed of lines corresponding to input datasets in the same order, each line of which containing the candidate number of the winner. No other characters should appear in the output.

Sample Input
 Copy sample input to clipboard
3 2
3 3
3 50
10 29
31 32
50 2
50 50
0 0
Sample Output
 
 

1 0 1 5 30 1 13


就是一直往右传当碗里有石子的话就那一颗,没有石子人手里有的话就将手里的石子都放入碗中,如果人手里也没石子的话就继续往右传;直到某个人拿到所有的石子结束;

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<cctype>
using namespace std;
int main()
{
    int n,p;
    int people[54];
    while(~scanf("%d%d",&n,&p)&&n&&p)
    {
        int flag=0;
        int pp=p;
        int winner;
        memset(people,0,sizeof(people));
        while(1)
        {
            for(int i=0; i<n; i++)
            {
                if(p)
                {
                    p--;
                    people[i]++;
                    if(people[i]==pp)
                    {
                        flag=1;
                        winner=i;
                        break;
                    }
                }
                else
                {
                    p+=people[i];
                    people[i]=0;
                }


            }
            if(flag)
                break;
        }
        printf("%d\n",winner);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值