Elevator

题目描述
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

输入
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

输出
Print the total time on a single line for each test case.

样例输入
1 2
3 2 3 1
0
样例输出
17
41

题目大致就是说电梯运行过程中,向上一层6秒,向下一层4秒,在指定层数停5秒,有两个注意点就是,起始位置为0层,且要将最后一层所停的时间算在内。

#include<stdio.h>
int main()
{
    int i,j,b,p,n;
    while(scanf("%d",&n)!=EOF)
    {
        int sum=0;
        int a[101];
        if(n==0)
        break;
        else
        {
            a[0]=0;
            for(i=1;i<=n;i++)
            {
                scanf("%d",&a[i]);
                /*if(a[i]==a[i-1])
                {
                    sum+=5;
                }*/
                if(a[i]>a[i-1])
                {
                    sum+=(a[i]-a[i-1])*6+5;
                }   
                if(a[i]<a[i-1])
                {
                    sum+=(a[i-1]-a[i])*4+5;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
 } 

以上代码如果没有/* */之间的内容,oj是通不过的,因为没有考虑到,如果下一次指定到达的层数与当层数相同的情况。不过我觉得还真不用考虑,没有人会站在5楼的电梯上,去往5楼,还要为此停5秒。

#include <stdio.h>
int main()
{
    int n;
    while (scanf("%d",&n),n)
    {
        int a,b=0,t,s=0;
        while (n--)
        {
            scanf("%d",&a);
            s+=(t=a-b)>0?t*6+5:-t*4+5;
            b=a;
        }
        printf("%d\n",s);
    }
    return 0;
}

更为简便的方法,用while (scanf(“%d”,&n),n)来结束n为0时的循环,用到了x>y?x:y的语句,在只有两种数据实现的情况下,这种语句是非常简便的。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值