JP Partition(gcd)

时间限制: 1 Sec 内存限制: 128 MB

题目描述
You are given integers N and M.
Consider a sequence a of length N consisting of positive integers such that a1+a2+…+aN = M. Find the maximum possible value of the greatest common divisor of a1,a2,…,aN.

Constraints
·All values in input are integers.
·1≤N≤105
·N≤M≤109
输入
Input is given from Standard Input in the following format:
N M

输出
Print the maximum possible value of the greatest common divisor of a sequence a1,a2,…,aN that satisfies the condition.

样例输入 Copy
3 14
样例输出 Copy
2
提示
Consider the sequence (a1,a2,a3)=(2,4,8). Their greatest common divisor is 2, and this is the maximum value.

题意:给出n、m。n个数相加和为m,求n个数最大公约数的最大值。

思路:正面想如何找n个数,使其和为m,并最大公约数最大,不好做。 我们可以转换一下,遍历可能满足的数k作为最大公约数!
因为k是所有数的最大公约数,那所有的数都可以整除k
那n个数相加就可以表示为:a1k+a2k+a3k+...ank。其中,ai是常系数。
那么,m就可以整除k!
至少所有的数都是k,所以要满足m/k>=n

Code:
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;

const int N=10010;
int n,m,a[N],ans,x;

int main(){
	cin>>n>>x;
	for(int i=x/n;i>=1;i--) //至少n个最大公约数k构成x,故从x/n枚举 
	{
		if(x%i==0&&x/i>=n){
			cout<<i;
			return 0;
		}
	}
	return 0;
} 

这么基础的数论都没能做出来。。看来数论得下大功夫了!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值