时间限制: 1 Sec 内存限制: 128 MB
题目描述
You are given integers N and M.
Consider a sequence a of length N consisting of positive integers such that a1+a2+…+aN = M. Find the maximum possible value of the greatest common divisor of a1,a2,…,aN.
Constraints
·All values in input are integers.
·1≤N≤105
·N≤M≤109
输入
Input is given from Standard Input in the following format:
N M
输出
Print the maximum possible value of the greatest common divisor of a sequence a1,a2,…,aN that satisfies the condition.
样例输入 Copy
3 14
样例输出 Copy
2
提示
Consider the sequence (a1,a2,a3)=(2,4,8). Their greatest common divisor is 2, and this is the maximum value.
题意:给出n、m。n个数相加和为m,求n个数最大公约数的最大值。
思路:正面想如何找n个数,使其和为m,并最大公约数最大,不好做。 我们可以转换一下,遍历可能满足的数k
作为最大公约数!
因为k
是所有数的最大公约数,那所有的数都可以整除k
!
那n个数相加就可以表示为:a1k+a2k+a3k+...ank
。其中,ai
是常系数。
那么,m就可以整除k!
至少所有的数都是k,所以要满足m/k>=n
;
Code:
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
const int N=10010;
int n,m,a[N],ans,x;
int main(){
cin>>n>>x;
for(int i=x/n;i>=1;i--) //至少n个最大公约数k构成x,故从x/n枚举
{
if(x%i==0&&x/i>=n){
cout<<i;
return 0;
}
}
return 0;
}
这么基础的数论都没能做出来。。看来数论得下大功夫了!