Highways

Highways

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0
Sample Output
692
Hint
Huge input,scanf is recommended.

求最大的权值,看了好久才明白题意,哎,,

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
const int MAX=2e2;
using namespace std;
int father[MAX];
int a[1000][1000];
void init(int n)
{
	for( int i = 0 ; i <= n ; i ++)
	  {
	  	   father[i] = i;
	  }
}
int find (int x)
{
	   if(x != father[x])
	   {
	   	 return father[x] = find(father[x]);
	   }
	  return x;
}
int unite(int a,int b)
{
	  int fa = find(a);
	  int fb = find(b);
	  if( fa != fb)
	  {
	  	   father[fa] = fb;
	  	   return 1;
	  }
	  return 0;
}
struct node 
{
	int st;
	int endd;
	int cost;
}p[20000];
bool cmp(node a,node b)
{
	return a.cost < b.cost;
}
int main()
{
	 int t;
	scanf("%d",&t);
	while(t--)
	{
		  int n;
		  scanf("%d",&n);
		  init(n);
		  int ans=-1;
		  for(int i = 1 ; i <= n ; i++ )
		    for(int j =1 ; j <= n ; j++)
		       {
		       	   scanf("%d",&a[i][j]);
		       	   if(i < j)
					   {  
					      ans++;
					   	   p[ans].st = i;
							  p[ans].endd = j; 
					   	   p[ans].cost = a[i][j];
						} 
			   }
		     sort ( p , p+ans+1, cmp);
		     int max=0,t=0;
		     for(int i = 0 ; i <= ans ; i++)
		      {
		      	   if (unite(p[i].st , p[i].endd))
		      	    {
		      	    	   max = p[i].cost;
		      	    	   t++;
					  }
					  if( t == n-1 )
					  break;
			  }
		     
		     printf("%d\n",max);
	}
	return 0;}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值