字符串的统计

 字符串的统计
Time Limit:2000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

Description

给定n个字符串,我想知道第i个字符串已经出现多少次?

Input

第一行输入一个整数t,代表t(t <= 20)组测试数据。

每组数据第一行输入一个整数n,代表字符串数目。接下来n行,每行输入一个字符串str。

保证:1 <= n <= 20000,1 <= |str| <= 20。

Output

每组数据输出n个结果,每个结果占一行,第i个结果表示第i个字符串已经出现了多少次。

Sample Input

3
2
aa
aa
3
aa
ab
aa
4
aaaa
ccaa
aacc
ccaa

Sample Output

0
1
0
0
1
0
0
0
1

Hint


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
using namespace std;
char str[32];
 map< string, int > mp;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		memset(str , 0 , sizeof(str));
		mp.clear();
		scanf("%d",&n);
		while(n--)
		{
			 scanf("%s",str);
			 printf("%d\n",mp[str]++);
		}
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值