A New Stone Game
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 5845 | Accepted: 3201 |
Description
Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.
Input
The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.
The last test case is followed by one zero.
Output
For each test case, if Alice win the game,output 1,otherwise output 0.
Sample Input
3 2 1 3 2 1 1 0
Sample Output
1 0
题意:
男人八题之一:
* 给定n堆石头,每次可以进行的操作为:
* 在有石头的任意一堆中,第一步:除去至少一个石头(必须操作)
* 第二步:取改堆中剩下的任意个石头以任意的方式放到其他任意有石头的堆里(这一步可以不操作)
* 最后不能操作的人输。
/*
*男人八题之一:
* 给定n堆石头,每次可以进行的操作为:
* 在有石头的任意一堆中,第一步:除去至少一个石头(必须操作)
* 第二步:取改堆中剩下的任意个石头以任意的方式放到其他任意有石头的堆里(这一步可以不操作)
* 最后不能操作的人输。
* 思路:将堆按石头数目排序,如果总堆数是基数,先手必胜,偶数的情况下从前到后两个堆一组,总共n/2组,
* 即某一堆不能既在前一组又在后一组中,如果所有组里面两堆石头都相同,先手败,只要有一组里面不同,先手必胜。
* 总堆数为奇数一定能将石头最多的那一堆去填补前面的组使其所有组中两堆石头的石头数目相同,再把剩下的剔除,
* 同理如果偶数堆时存在多组不相同的我们就取两堆中石头数较多并且在所有不同组中石头数最多的那组,
* 将前面的不同堆数的组都填成相等,再把多余的石头除去,使所有组的两堆有相同数目的石头
*/
#include <iostream>
#include <algorithm>
#define endl "\n"
using namespace std;
int main()
{
ios::sync_with_stdio(false);
int n;
while(cin >> n) {
if(!n) break;
int ans = 0, num[14];
for(int i = 0; i < n; ++i) {
cin >> num[i];
}
if(n & 1) {
cout << 1 << endl;
}
else {
sort(num, num+n);
for(int i = 0; i < n-1; i += 2) {
if(num[i] != num[i+1])
ans = 1;
}
cout << ans << endl;
}
}
return 0;
}