HUD Crazy Bobo 树上dfs

Crazy Bobo


Problem Description
Bobo has a tree,whose vertices are conveniently labeled by 1,2,...,n.Each node has a weight  wi . All the weights are distrinct.
A set with m nodes  v1,v2,...,vm  is a Bobo Set if:
- The subgraph of his tree induced by this set is connected.
- After we sort these nodes in set by their weights in ascending order,we get  u1,u2,...,um ,(that is, wui<wui+1  for i from 1 to m-1).For any node  x  in the path from  ui  to  ui+1 (excluding  ui  and  ui+1 ),should satisfy  wx<wui .
Your task is to find the maximum size of Bobo Set in a given tree.
 

Input
The input consists of several tests. For each tests:
The first line contains a integer n ( 1n500000 ). Then following a line contains n integers  w1,w2,...,wn  ( 1wi109 ,all the  wi  is distrinct).Each of the following n-1 lines contain 2 integers  ai  and  bi ,denoting an edge between vertices  ai  and  bi  ( 1ai,bin ).
The sum of n is not bigger than 800000.
 

Output
For each test output one line contains a integer,denoting the maximum size of Bobo Set.
 

Sample Input
  
  
7 3 30 350 100 200 300 400 1 2 2 3 3 4 4 5 5 6 6 7
 

Sample Output
  
  
5

 
/*
 * 在原图中,w[u] < w[v] 则加边 u -> v , 反之加边 v -> u
 */
#include <bits/stdc++.h>
#define endl "\n"
using namespace std;
typedef long long ll;

const int MAXN = 500000 + 7;
vector<int> linker[MAXN];
int vis[MAXN];
int val[MAXN];
int n, ans = 0;
void Init(){
    for(int i = 0; i <= n; ++i) {
        linker[i].clear();
    }
}

int dfs(int u) {
    if(vis[u]) return vis[u];
    vis[u] = 1;
    for(int i = 0; i < linker[u].size(); ++i) {
        int v = linker[u][i];
        vis[u] += dfs(v);
        ans = max(ans, vis[u]);
    }
    return vis[u];
}

int main() {
    ios::sync_with_stdio(false);
    while(cin >> n) {
        Init();
        for(int i = 1; i <= n; ++i) {
            cin >> val[i];
            vis[i] = 0;
        }
        int a, b;
        for(int i = 1; i < n; ++i) {
            cin >> a >> b;
            if(val[a] < val[b]) {
                linker[a].push_back(b);
            }
            else {
                linker[b].push_back(a);
            }
        }
        ans = 1;
        for(int i = 1; i <= n; ++i) {
            dfs(i);
        }
        cout << ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值