HDU1042


N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 66879    Accepted Submission(s): 19171




Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 


Input
One N in one line, process to the end of file.
 


Output
For each N, output N! in one line.
 


Sample Input
1
2
3
 


Sample Output
1
2
6
 
这个题目不是很难,一次性过得。首先我定义了一个数组r[5000],尽量大些。然后,用数组中的每个位置存大数阶乘的5个数。
列如:13!=6227020800,则利用r[0]=20800,r[1]=62270。又13!=r[1]*100000 + r[0],所以r[0]* = 14,后r[0]的值为291200;
r[1]* = 14, 后r[1]的值为871780;所以14!=r[1]*100000 + r[0],

<pre name="code" class="csharp">
 

#include<stdio.h>
int main()
{
	unsigned long r[50000]={0};//首先定义一个大一点的数组; 
	int i,j,k,f,m,n,d;
	while(~scanf("%d",&k))
	{
		r[0]=1;f=0;
		for(i=2;i<=k;i++)
		{
			for(j=0;j<=f;j++)
			{
				r[j]*=i;
			}
			for(j=0;j<=f;j++)//因为数组中的每一个数是存了五位数的; 
			{
			  m=r[j]/100000;//对数组进行进位处理; 
			  r[j+1]+=m;
			  r[j]=r[j]%100000;
			}
			if(r[f+1]>0)
			f++;
		}
		printf("%d",r[f]);//对结果进行输出; 
		r[f]=0;
		n=1;
		for(i=f-1;i>=0;i--)
		{
			printf("%05d",r[i]);
			r[i]=0;
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值