HDU1002 A + B Problem II

A + B Problem II


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 288730    Accepted Submission(s): 55483




Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 


Sample Input
2
1 2
112233445566778899 998877665544332211
 


Sample Output
Case 1:
1 + 2 = 3


Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110



            这个题的格式啊!!!  注意他的输出格式,这个题木我是用两个字符数组加一个整型数组做出来的!

#include<stdio.h>
#include<string.h>
char a[1005],b[1005];
int c[10005];
int main()
{
	int i,j,n,m,t,l,l1,l2;
	scanf("%d",&t);
	for(l=1;l<=t;l++)
	{
		scanf("%s%s",a,b);
		l1=strlen(a);
		l2=strlen(b);
		int ka,kb,k1=0,k2,k,p=0;
		//int l3=l1>l2?l1:l2;
		for(i=l1-1,j=l2-1;i>=0||j>=0;j--,i--)
		{
			if(i>=0)
			ka=(a[i]-'0');
			if(j>=0)
			kb=(b[j]-'0');
			k=ka+kb+k1;
			k1=k/10;
			k2=k%10;
			c[p++]=k2;
			ka=0;kb=0;
		}
		printf("Case %d:\n",l);
		printf("%s + %s = ",a,b);
		for(i=p-1;i>=0;i--)
		printf("%d",c[i]);
		if(l!=t)
		printf("\n\n");
		else
		printf("\n");
	}
	return 0;
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值