HDU 1761—简单的字典树,需要释放内存

Phone List

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17037 Accepted Submission(s): 5737

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO
YES

题目大意就是给你一堆电话号码,看看之前的电话有没有是当前电话的前缀的,有则输出NO,反之YES

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;

typedef struct Trie_Node
{
    struct Trie_Node* nexts[10];
    bool exist;
} TrieNode,*Trie;

TrieNode* creat_node()
{
    TrieNode *node= new TrieNode;
    memset(node->nexts,NULL,sizeof(node->nexts));
    node->exist=false;
    return node;
}

bool insertNode(TrieNode *root,char *str)
{
    int id;
    TrieNode *p=root;
    for(int i=0;str[i];i++)
    {
        id=str[i]-'0';
        if(p->nexts[id]==NULL)
        {
            p->nexts[id]=creat_node();
            p=p->nexts[id];
        }
        else
        {
            p=p->nexts[id];
            if(p->exist)
                return true;
        }
    }
        p->exist=true;
    for(int i=0;i<10;i++)//这里也是个坑,就是当就是好之后看看当前串后面有没有别的串,如果有说明当前串为其他串的前缀。
        if(p->nexts[i]!=NULL)
            return true;

    return false;
}

void release(TrieNode *root)
{
        if(root==NULL)
            return ;
    for(int i=0; i<10; i++)
        if(root->nexts[i]!=NULL)
            release(root->nexts[i]);

        delete (root);
}

int main()
{

    int t,p;
    bool flag;
    char str[15];
    scanf("%d",&t);
    while(t--)
    {
        flag=false;
        TrieNode* root=creat_node();
        scanf("%d",&p);
        while(p--)
        {
            cin>>str;
            if(!flag)
                flag=insertNode(root,str);
        }
      //  cout<<"**************"<<endl;
        if(!flag) printf("YES\n");
        else printf("NO\n");
        release(root);   //这里很重要,要不MME
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值