hdu 6186 CS Course 前缀后缀问题

CS Course

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1166    Accepted Submission(s): 560


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap .
 

Input
There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers a1,a2,,an follows in a line, 0ai109 for each i in range[1,n].

After that there are q positive integers p1,p2,,pq in q lines, 1pin for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0
 

Source

2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)  

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define nsize 100010
int a[nsize];
int frontAnd[nsize], frontOr[nsize], frontXor[nsize];
int behindAnd[nsize], behindOr[nsize], behindXor[nsize];

int main()
{
	int n, m;
	int q;
	while (cin >> n >> m) {
		cin >> a[1];
		frontAnd[1] = frontOr[1] = frontXor[1] = a[1];
		for (int i = 2; i <= n; i++) {
			cin >> a[i];
			frontAnd[i] = a[i] & frontAnd[i - 1];
			frontOr[i] = a[i] | frontOr[i - 1];
			frontXor[i] = a[i] ^ frontXor[i - 1];
		}
		behindAnd[n] = behindOr[n] = behindXor[n] = a[n];
		for (int i = n - 1; i >= 1; i--) {
			behindAnd[i] = behindAnd[i + 1] & a[i];
			behindOr[i] = behindOr[i + 1] | a[i];
			behindXor[i] = behindXor[i + 1] ^ a[i];
		}
		for (int i = 0; i < m; i++) {
			cin >> q;
			if (q == 1)
				printf("%d %d %d\n", behindAnd[q + 1], behindOr[q + 1], behindXor[q + 1]);
			else if (q == n)
				printf("%d %d %d\n", frontAnd[q - 1], frontOr[q - 1], frontXor[q - 1]);
			else
				printf("%d %d %d\n", frontAnd[q - 1] & behindAnd[q + 1], frontOr[q - 1] | behindOr[q + 1], frontXor[q - 1] ^ behindXor[q + 1]);
		}
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值