PAT甲级 1027 Colors in Mars(20) (字符串)

题目

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

输入

Each input file contains one test case which occupies a line containing the three decimal color values.

输出

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

样例输入 

15 43 71

样例输出 

#123456

题意理解

给你三个10进制数字让你转换成13进制的数,这个数转换完以后必须占两个位,也就是哪怕是0也要输出00,那么我们用字符串处理即可,记得前面加个#。

代码 

#include<bits/stdc++.h> 
using namespace std;
typedef long long LL;
typedef unsigned long long ULL ;
typedef pair<int,int> PII;
typedef pair<double,double> PDD;
#define fx first
#define fy second
const int INF=0x3f3f3f3f;
const LL  LINF=1e18;
const int N=2e5+10;
const int M=2e2+10;
const int MOD=1e9+7;
int n,m;
char turn(int x){
     if(x>=0&&x<=9)return x+'0';
     else return x-10+'A';
}
string radix(int  x){
    string res="00";
    res[1]=turn(x%13);
    res[0]=turn(x/13);
    return res;
}
void solve(){
     string ss="#";
     for(int i=1;i<=3;i++){
         int x;cin>>x;
         ss+=radix(x);
     }
     cout<<ss<<endl;
}
int main(){
    int T=1;
    ios::sync_with_stdio(0);
    cin.tie(0);cout.tie(0);
    while(T--){
    	solve();
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值