PoJ 3252 Round Numbers 数位DP

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6


题目描述:

这题是要求a到b里有多少round number(一下简称RN),RN就是二进制表示中0的个数大于等于1的个数的数


题解:

要求RN,显然第一种方法是求小于一个数的数中有多少数满足,这里我们用组合数来求,比如现在在dfs的时候,现在的0和1的个数差值是0,还剩五个位置,现在可以随意填,那么我们就有C(5,3) + C(5,4)+C(5,5)
这是很显然的一种解法,这里说一种另外的解法

现在我们用sta来表示0的个数减去1的个数+32之后的这个数,为什么要+32呢,因为如果先前的0比1少,但是后来如果0比较多的话,仍然可能让他是一个round number,这样+32只是为了方便记忆化,毕竟数组下标不能为负数,这对于我来说是新操作233,%%%

然后我们传一个

int dfs( int pos, int sta, bool lead, bool limit ) 

其中sta的含义已经表示,pos表示当前讨论的是哪一位,从小到大,lead表示是否求前导零,limit表示是否有限制

int dfs( int pos, int sta, bool lead, bool limit ) {
    if( pos == -1 ) return sta >= 32;
    if( !limit && !lead ) return dp[pos][sta];
    int up = limit ? a[pos] : 1;
    int ans = 0;
    for( register int i = 0; i <= up; i++ ) {
        if( lead && i == 0 ) ans += dfs( pos - 1, sta, lead, limit && i == up );
        else                 ans += dfs( pos - 1, sta + ( i == 0 ? 1 : -1 ), lead && i == 0, limit && i == up );
    }
    if( !limit && !lead ) dp[pos][sta] = ans;
    return ans;
}

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dp[66][66], a[66]; 
int dfs( int pos, int sta, bool lead, bool limit ) { // sta表示0的个数减去1的个数 +32 
    if( pos == -1 ) return sta >= 32;
    if( !limit && !lead && dp[pos][sta] != -1 ) return dp[pos][sta];
    int up = limit ? a[pos] : 1;
    int ans = 0;
    for( register int i = 0; i <= up; i++ ) {
        if( lead && i == 0 ) ans += dfs( pos - 1, sta, lead, limit && i == up );
        else                 ans += dfs( pos - 1, sta + ( i == 0 ? 1 : -1 ), lead && i == 0, limit && i == up );         
    }
    if( !limit && !lead ) dp[pos][sta] = ans;
    return ans;
}

int solve( int n ) {
    int len = 0;
    while( n ) {
        a[len++] = n & 1;
        n >>= 1; 
    }
    return dfs( len - 1, 32, true, true );
} 

int main( ) { int a, b; memset( dp, -1, sizeof(dp) );   
    while( ~scanf( "%d%d", &a, &b ) ) 
        printf( "%d\n", solve( b ) - solve( a - 1 ) );
    return 0;
}

这里写图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 给出一个$n\times m$的矩阵,每个位置上有一个非负整数,代表这个位置的海拔高度。一开始时,有一个人站在其中一个位置上。这个人可以向上、下、左、右四个方向移动,但是只能移动到海拔高度比当前位置低或者相等的位置上。一次移动只能移动一个单位长度。定义一个位置为“山顶”,当且仅当从这个位置开始移动,可以一直走到海拔高度比它低的位置上。请问,这个矩阵中最多有多少个“山顶”? 输入格式 第一行两个整数,分别表示$n$和$m$。 接下来$n$行,每行$m$个整数,表示整个矩阵。 输出格式 输出一个整数,表示最多有多少个“山顶”。 样例输入 4 4 3 2 1 4 2 3 4 3 5 6 7 8 4 5 6 7 样例输出 5 算法1 (递归dp) $O(nm)$ 对于这道题,我们可以使用递归DP来解决,用$f(i,j)$表示以$(i,j)$为起点的路径最大长度,那么最后的答案就是所有$f(i,j)$中的最大值。 状态转移方程如下: $$ f(i,j)=\max f(x,y)+1(x,y)是(i,j)的下一个满足条件的位置 $$ 注意:这里的状态转移方程中的$x,y$是在枚举四个方向时得到的下一个位置,即: - 向上:$(i-1,j)$ - 向下:$(i+1,j)$ - 向左:$(i,j-1)$ - 向右:$(i,j+1)$ 实现过程中需要注意以下几点: - 每个点都需要搜一遍,因此需要用双重for循环来枚举每个起点; - 对于已经搜索过的点,需要用一个数组$vis$来记录,防止重复搜索; - 在进行状态转移时,需要判断移动后的点是否满足条件。 时间复杂度 状态数为$O(nm)$,每个状态转移的时间复杂度为$O(1)$,因此总时间复杂度为$O(nm)$。 参考文献 C++ 代码 算法2 (动态规划) $O(nm)$ 动态规划的思路与递归DP类似,只不过转移方程和实现方式有所不同。 状态转移方程如下: $$ f(i,j)=\max f(x,y)+1(x,y)是(i,j)的下一个满足条件的位置 $$ 注意:这里的状态转移方程中的$x,y$是在枚举四个方向时得到的下一个位置,即: - 向上:$(i-1,j)$ - 向下:$(i+1,j)$ - 向左:$(i,j-1)$ - 向右:$(i,j+1)$ 实现过程中需要注意以下几点: - 每个点都需要搜一遍,因此需要用双重for循环来枚举每个起点; - 对于已经搜索过的点,需要用一个数组$vis$来记录,防止重复搜索; - 在进行状态转移时,需要判断移动后的点是否满足条件。 时间复杂度 状态数为$O(nm)$,每个状态转移的时间复杂度为$O(1)$,因此总时间复杂度为$O(nm)$。 参考文献 C++ 代码

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值