Multiply game(线段树)

Multiply game

跟排兵布阵不一样的是,这里的每个节点是所对应一段区间的所有数字的积
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 12
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

Input

The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.

Output

For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.

Sample Input

1
6
1 2 4 5 6 3
3
0 2 5
1 3 7
0 2 5

Sample Output

240
420

#include <iostream>
#include <cstdio>
#define M 50005
#define mod 1000000007
using namespace std;
struct node
{
int left;
int right;
__int64 sum;
};
node tree[M<<2];
int a[M];
void build(int l,int r,int step)
{
tree[step].left=l;
tree[step].right=r;
if(l==r) {tree[step].sum=a[l];return;}
build(l,(l+r)/2,step*2);
build((l+r)/2+1,r,step*2+1);
tree[step].sum=tree[step*2].sum*tree[step*2+1].sum%mod;
}
__int64 query(int l,int r,int step)
{
if (tree[step].left >= l && tree[step].right<=r)
{
return tree[step].sum;
}
int mid = (tree[step].left+tree[step].right)/2;
__int64 ret = 1;
if (l<=mid) ret = ret*query(l,r,step*2)%mod;
if (r>mid) ret =ret*query(l,r,step*2+1)%mod;
return ret;
}
void updata(int a1,int a2,int step)
{
if (tree[step].left == tree[step].right)
{
tree[step].sum =a2;
return;
}

int mid = (tree[step].left+tree[step].right)/2;
if (a1<=mid) updata(a1,a2,step*2);
else updata(a1,a2,step*2+1);
tree[step].sum = tree[step*2].sum * tree[step*2+1].sum%mod;
}
int main(int argc, char *argv[])
{
int t,n,i,q,x;
__int64 num;
int a1,a2;
cin>>t;
while(t--)
{
cin>>n;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
build(1,n,1);
cin>>q;
for(i=0;i<q;i++)
{
scanf("%d%d%d",&x,&a1,&a2);
if(x==0) {num=query(a1,a2,1);printf("%I64d\n",num);}
else if(x==1) updata(a1,a2,1);
}
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值