Invitation Cards(最短路径之SPFA算法)

Invitation Cards

本题大意:有n个公交站站点,有那个志愿者,要求每个志愿者到一个公交站点接待路人,站台号为1,2,3到n,所有的志愿者从1号站台 出发,最后还要全部返回1号站台,但是这里的公交车比较奇怪,总是在两个站台之间来往,而且只往一个方向载客,不同的路线费用不同,其实就是一个简单的有向路径模型,问所有志愿者一天最少的花费。
用SPFA找到1号到所有站台的最小路径(也就是最少费用),回来的车费的算法要把所有的路径方向反过来,在算一遍1号到所有站台的最小路径,全部求和就可以了。
Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop. 

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers. 

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

#include <iostream>
#include <queue>
#include <cstdio>
#define INF 1000000000
#define MAXN 1000000
using namespace std;
struct ArcNode
{
int to;
int weight;
ArcNode *next;
};
queue<int> Q;
int n,m;
ArcNode *List[MAXN];
ArcNode *List1[MAXN];
int inq[MAXN];
int dist[MAXN],path[MAXN],dist1[MAXN];
void SPFA(int src)
{
int i,u;
ArcNode *temp;
for(i=1;i<=n;i++)
{
dist[i]=INF;path[i]=src;inq[i]=0;
}
dist[src]=0;path[src]=src;inq[src]++;
Q.push(src);
while(!Q.empty())
{
u=Q.front();Q.pop();inq[u]--;
temp=List[u];
while(temp!=NULL)
{
int v=temp->to;
if(dist[v]>dist[u]+temp->weight)
{
dist[v]=dist[u]+temp->weight;path[v]=u;
if(!inq[v]){Q.push(v);inq[v]++;}
}
temp=temp->next;
}
}
}
void SPFA1(int src)
{
int i,u;
ArcNode *temp;
for(i=1;i<=n;i++)
{
dist1[i]=INF;path[i]=src;inq[i]=0;
}
dist1[src]=0;path[src]=src;inq[src]++;
Q.push(src);
while(!Q.empty())
{
u=Q.front();Q.pop();inq[u]--;
temp=List1[u];
while(temp!=NULL)
{
int v=temp->to;
if(dist1[v]>dist1[u]+temp->weight)
{
dist1[v]=dist1[u]+temp->weight;path[v]=u;
if(!inq[v]){Q.push(v);inq[v]++;}
}
temp=temp->next;
}
}
}
int main(int argc, char *argv[])
{
int i,j;
int sum;
int u,v,w,t;
cin>>t;
while(t--)
{
cin>>n>>m;
sum=0;
memset(List,0,sizeof(List));
ArcNode *temp;
for(i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&w);
temp=new ArcNode;
temp->to=v;temp->weight=w;temp->next=NULL;
if(List[u]==NULL) List[u]=temp;
else {temp->next=List[u];List[u]=temp;}
temp=new ArcNode;
temp->to=u;temp->weight=w;temp->next=NULL;
if(List1[v]==NULL) List1[v]=temp;
else {temp->next=List1[v];List1[v]=temp;}
}
SPFA(1); //求了两遍,一遍是正的
SPFA1(1); //一遍是把所有路径反过来的
for(i=2;i<=n;i++) {sum+=dist[i];sum+=dist1[i];}
for(j=0;j<n;j++)
{
temp=List[j];
while(temp!=NULL)
{
List[j]=temp->next;delete temp;temp=List[j];
}
}
for(j=0;j<n;j++)
{
temp=List1[j];
while(temp!=NULL)
{
List1[j]=temp->next;delete temp;temp=List1[j];
}
}
cout<<sum<<endl;
}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值