On the circuit board, there are lots of circuit paths. We know the basic constrain is that no two path cross each other, for otherwise the board will be burned.
Now given a circuit diagram, your task is to lookup if there are some crossed paths. If not find, print "ok!", otherwise "burned!" in one line.
A circuit path is defined as a line segment on a plane with two endpoints p1(x1,y1) and p2(x2,y2).
You may assume that no two paths will cross each other at any of their endpoints.
Input
The input consists of several test cases. For each case, the first line contains an integer n(<=2000), the number of paths, then followed by n lines each with four float numbers x1, y1, x2, y2.
Output
If there are two paths crossing each other, output "burned!" in one line; otherwise output "ok!" in one line.
Sample Input
1
0 0 1 1
2
0 0 1 1
0 1 1 0
Sample Output
ok!
burned!
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
struct node1
{
double x,y;
}point[4005];
struct node2
{
node1 a,b;
}line[2005];
//叉积
double mult(node1 a, node1 b, node1 c)
{
return 1.0*(a.x-c.x)*(b.y-c.y)-1.0*(b.x-c.x)*(a.y-c.y);
}
//aa, bb为一条线段两端点 cc, dd为另一条线段的两端点 相交返回true, 不相交返回false
bool judge(node1 aa, node1 bb, node1 cc, node1 dd)
{
if ( max(aa.x, bb.x)<min(cc.x, dd.x) )
{
return false;
}
if ( max(aa.y, bb.y)<min(cc.y, dd.y) )
{
return false;
}
if ( max(cc.x, dd.x)<min(aa.x, bb.x) )
{
return false;
}
if ( max(cc.y, dd.y)<min(aa.y, bb.y) )
{
return false;
}
if ( mult(cc, bb, aa)*mult(bb, dd, aa)<0 )
{
return false;
}
if ( mult(aa, dd, cc)*mult(dd, bb, cc)<0 )
{
return false;
}
return true;
}
int main(int argc, char *argv[])
{
int i,j,t;
while(cin>>t)
{
for(i=0;i<t;i++)
{
scanf("%f%f%f%f",&line[i].a.x,&line[i].a.y,&line[i].b.x,&line[i].b.y);
}
bool a=true;
if(t==1)
{
cout<<"ok!"<<endl;
continue;
}
for(i=0;i<t-1;i++)
{
for(j=i+1;j<t;j++)
{
if(judge(line[i].a,line[i].b,line[j].a,line[j].b)==true)
{
a=false;break;
}
}
if(!a) break;
}
if(a) cout<<"ok!"<<endl;
else cout<<"burned!"<<endl;
}
return 0;
}