square (回溯)

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20,the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3

4 1 1 1 1

5 10 20 30 40 50

8 1 7 2 6 4 4 3 5
Sample Output
yes
no

yes

#include <iostream>
#include <algorithm>
#include <cstdio>  
#include <cstring>  
using namespace std;

int sum;  //正方形的边长 
int sticks[22];
int used[22]={0};  //判断小木棍是否被使用 
int num;
int flag;  //判断YES or no 

void square(int length){   //length当前长度 
//	cout<<"length "<<length<<"sum"<<sum<<endl;
	int i;
	if(length>sum)
		return;
	
	if(length==sum){
		num++;
		for(i=0;i<m;i++){
			if(!used[i]){
				used[i]=1;
				square(sticks[i]);
				used[i]=0;
			}
		}
		if(num==4)
			flag=1;
	}
	else{
		for(i=0;i<m;i++){
			if(!used[i] && length+sticks[i]<=sum){
				used[i]=1;
				square(length+sticks[i]);
				used[i]=0;
			}
		}
	}
}

int main(){
	int n;
	int i,j;
	cin>>n;
	
	while(n--){
		cin>>m;
		sum=0;
		flag=0;
		memset(used,0,sizeof(used));
		for(i=0;i<m;i++){
			cin>>sticks[i];
			sum+=sticks[i];
		}
		if(sum%4==0){
			sum=sum/4;
			for(i=0;i<m;i++){
				if(sticks[i]>sum){
					cout<<"no"<<endl;
					return 0;
				}
			}
			num=0;
			used[0]=1;
			square(sticks[0]);
		}
		if(flag) cout<<"yes"<<endl;
		else cout<<"no"<<endl;
		
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值