习题二1003

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2

Sample Output

  
  
25.1327 3.1416 50.2655

 题意:

生日聚会上,来到的所有朋友都会领取一块饼,但是要求的是所有人都要拿到大小相同的饼!题目要求输出的是:每个人尽量拿到的最大的饼的体积是多大。这里的饼的形状是高为1的圆柱形。V=底面积*高。

解题思路:

求出每块饼的面积s[i],并记录面积最大的s[i]为maxs,然后在0~maxs之间进行二分得到mid,判断是否每个人都能得到面积为mid的饼,如果能则mid=left,否则right=mid。

特别注意:

1、题目里要给你自己留一块。
2、每个人得到的饼不可以是两块饼拼接在一起的。
3、这里的PI要用acos(-1.0),具体原因还不知道为什么,可能精度要求比较高,因为这里wa几次。0.0

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<cmath>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10000+10;
const double PT=3.14159265358979323846;
double s[MAX];
int t,n,m;

bool search(double v){
	int sum=0;
	for(int i=0;i<n;++i){
		sum+=(int)(s[i]/v);
	}
	if(sum>=m)return true;
	else return false;
} 

int main(){
	cin>>t;
	while(t--){
		cin>>n>>m;
		++m;
		double maxs=-INF,mins=0,mid=0;
		for(int i=0;i<n;++i){
			cin>>s[i];
			s[i]=PT*s[i]*s[i];
			maxs=max(maxs,s[i]*1.0);
		}
		while(fabs(mins-maxs)>1e-6){
			mid=(mins+maxs)/2;
			if(search(mid))mins=mid;
			else maxs=mid;
		}
		cout<<fixed<<setprecision(4)<<mid<<endl;
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值