练习三1002

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit :65536/32768K (Java/Other)

Total Submission(s) : 4   Accepted Submission(s) : 4

Problem Description

A subsequence of a givensequence is the given sequence with some elements (possible none) left out.Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z =&lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists astrictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of Xsuch that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f,c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with indexsequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem isto find the length of the maximum-length common subsequence of X and Y.<br>The program input is from a text file. Each data set in the filecontains two strings representing the given sequences. The sequences areseparated by any number of white spaces. The input data are correct. For eachset of data the program prints on the standard output the length of themaximum-length common subsequence from the beginning of a separate line.<br>

 

 

Sample Input

abcfbc abfcab

programming contest

abcd mnp

 

 

Sample Output

4

2

0

 

题意:给出两个字符串,求两个字符串的最长公共字串。

解题思路:慢慢重心开始有贪心转向动态规划了,这题就是简单的动态规划题。以题目的第一组测试数据为例。abcfbc

 abfcab。

辅助空间变化示意图

 

可以看出:

F[i][j]=F[i-1][j-1]+1;(a[i]==b[j])

F[i][j]=max(F[i-1][j],F[i][j-1])(a[i]!=b[j]);

n由于F(i,j)只和F(i-1,j-1),F(i-1,j)和F(i,j-1)有关, 而在计算F(i,j)时, 只要选择一个合适的顺序, 就可以保证这三项都已经计算出来了, 这样就可以计算出F(i,j). 这样一直推到f(len(a),len(b))就得到所要求的解了.


#include<stdio.h>
#include<string.h>
int f[1001][1001];//**1001*1001太大不能定义在主函数,否则直接停止编译**//
int main()
{
    char a[1001],b[1001];
    int i,j,len1,len2;
    while(~scanf("%s %s",a,b))
    {
        len1=strlen(a);
        len2=strlen(b);
        for(i=0;i<=len1;i++)
        {
            f[i][0]=0;
        }
        for(i=0;i<=len2;i++)
        {
            f[0][i]=0;
        }
        for(i=1;i<=len1;i++)
        {
            for(j=1;j<=len2;j++)
            {
                if(a[i-1]==b[j-1])
                {
                    f[i][j]=f[i-1][j-1]+1;
                }
                else
                {
                    f[i][j]=f[i-1][j]>f[i][j-1]?f[i-1][j]:f[i][j-1];
                }
            }
        }
        printf("%d\n",f[len1][len2]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值