练习三1005

Problem E

Time Limit : 2000/1000ms (Java/Other)   Memory Limit :65536/32768K (Java/Other)

 

Problem Description

A group ofresearchers are designing an experiment to test the IQ of a monkey. They willhang a banana at the roof of a building, and at the mean time, provide themonkey with some blocks. If the monkey is clever enough, it shall be able toreach the banana by placing one block on the top another to build a tower andclimb up to get its favorite food.<br><br>The researchers have ntypes of blocks, and an unlimited supply of blocks of each type. Each type-iblock was a rectangular solid with linear dimensions (xi, yi, zi). A blockcould be reoriented so that any two of its three dimensions determined the dimensionsof the base and the other dimension was the height. <br><br>Theywant to make sure that the tallest tower possible by stacking blocks can reachthe roof. The problem is that, in building a tower, one block could only beplaced on top of another block as long as the two base dimensions of the upperblock were both strictly smaller than the corresponding base dimensions of thelower block because there has to be some space for the monkey to step on. Thismeant, for example, that blocks oriented to have equal-sized bases couldn't bestacked. <br><br>Your job is to write a program that determines theheight of the tallest tower the monkey can build with a given set ofblocks.<br>

 

 

Input

The input filewill contain one or more test cases. The first line of each test case containsan integer n,<br>representing the number of different blocks in thefollowing data set. The maximum value for n is 30.<br>Each of the next nlines contains three integers representing the values xi, yi and zi.<br>Inputis terminated by a value of zero (0) for n.<br>

 

 

Output

For each testcase, print one line containing the case number (they are numbered sequentiallystarting from 1) and the height of the tallest possible tower in the format"Case case: maximum height = height".<br>

 

 

Sample Input

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58

97 93 23

84 62 64

33 83 27

0

 

 

Sample Output

Case 1: maximumheight = 40

Case 2: maximumheight = 21

Case 3: maximumheight = 28

Case 4: maximumheight = 342

 

 

 

题意:

一道经典的DP题目,类似于求最长递增子序列吧。

一堆科学家研究猩猩的智商,给他M种长方体,每种N个。

然后,将一个香蕉挂在屋顶,让猩猩通过叠长方体来够到香蕉。

现在给你M种长方体,计算,最高能堆多高。

要求位于上面的长方体的长要大于(注意不是大于等于)下面长方体的长,上面长方体的宽大于下面长方体的宽。

 

解题思路:

一个长方体,可以有6种不同的摆法。

因为数据中长方体种类最多30种,也就是说数组最大可以开到 30*6=180 完全可以

然后用dp[i]来存,到第i个木块,最高可以累多高。

当然,长方体先要以长度排序,长度相同则宽度小的在上。

 

 

#include <iostream>
#include <algorithm>
using namespace std;
struct Cuboid
{
	int l, w, h;
}cd[181];
int dp[181];
// sort比较函数
bool cmp(Cuboid cod1, Cuboid cod2)
{
	if (cod1.l == cod2.l)	return cod1.w<cod1.w;
	return cod1.l<cod2.l;
}
int main()
{
	int i, j, n, len, t_num = 1;
	int z1, z2, z3;
	while (cin >> n && n)
	{
		len = 0;
		// 每组数都可以变换为6种长方体
		for (i = 0; i<n; ++i)
		{
			cin >> z1 >> z2 >> z3;
			cd[len].l = z1, cd[len].w = z2, cd[len++].h = z3;
			cd[len].l = z1, cd[len].w = z3, cd[len++].h = z2;
			cd[len].l = z2, cd[len].w = z1, cd[len++].h = z3;
			cd[len].l = z2, cd[len].w = z3, cd[len++].h = z1;
			cd[len].l = z3, cd[len].w = z1, cd[len++].h = z2;
			cd[len].l = z3, cd[len].w = z2, cd[len++].h = z1;
		}

		sort(cd, cd + len, cmp);
		dp[0] = cd[0].h;

		// 构建dp数组
		int max_h;
		for (i = 1; i<len; ++i)
		{
			max_h = 0;
			for (j = 0; j<i; ++j)
			{
				if (cd[j].l<cd[i].l && cd[j].w<cd[i].w)
					max_h = max_h>dp[j] ? max_h : dp[j];
			}
			dp[i] = cd[i].h + max_h;
		}

		// 再次搜索 所有dp中最大值
		max_h = 0;
		for (i = 0; i<len; ++i)
		if (max_h<dp[i])
			max_h = dp[i];
		// 输出
		cout << "Case " << t_num++ << ": maximum height = " << max_h << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值