POJ 3268 Silver Cow Party (最短路,置换矩阵)




One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1.. N is going to attend the big cow party to be held at farm # X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题意:n个点,m条单向边,每个点的牛都要到一个点k去并回来,要求来回路程的最大值。

刚开始看到这题,首先求出k点到每个点的最短距离,然后遍历每一个点到k点的距离,求出两段值的和的最大值。但这样显然会超时的。然后看到别人的博客说将矩阵置换一下就好了,原因可以这样理解:要求每个点到k点的最短距离,将路径反过来再求k点到每个点的最短距离,那么就变成了每个点到k点的最短距离了。

超时代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define N 1000
#define inf 0x3fffffff
int m,n,k,dis1[N+1],dis[N+1],e[N+1][N+1];
bool vis[N+1];
void dijkstra(int x)
{
    memset(vis,false,sizeof(vis));
    for(int i=0;i<n;i++)
        dis[i]=e[x][i];
    for(int i=0;i<n-1;i++)
    {
        int tmp=inf,u=-1;
        for(int j=0;j<n;j++)
        {
            if(tmp>dis[j]&&!vis[j]&&dis[j])
            {
                tmp=dis[j];
                u=j;
            }
        }
        if(u==-1) break;
        vis[u]=true;
        for(int j=0;j<n;j++)
        {
            if(j==x) continue;
            if(!vis[j]&&e[u][j]&&(dis[j]>dis[u]+e[u][j]||!dis[j]))
                dis[j]=dis[u]+e[u][j];
        }
    }
}
int main()
{
    int a,b,c,ans=0;
    scanf("%d%d%d",&n,&m,&k);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        e[a-1][b-1]=c;
    }
    for(int i=0;i<n;i++)
        dis1[i]=e[k-1][i];
    for(int i=0;i<n-1;i++)
    {
        int t=inf,uu=-1;
        for(int j=0;j<n;j++)
        {
            if(t>dis1[j]&&!vis[j]&&dis1[j])
            {
                t=dis1[j];
                uu=j;
            }
        }
        if(uu==-1) break;
        vis[uu]=true;
        for(int j=0;j<n;j++)
        {
            if(j==k-1) continue;
            if(!vis[j]&&e[uu][j]&&(dis1[j]>dis1[uu]+e[uu][j]||!dis1[j]))
                dis1[j]=dis1[uu]+e[uu][j];
        }
    }
//    for(int i=0;i<n;i++)
//        printf("%d ",dis1[i]);
    for(int i=0;i<n;i++)
    {
        if(i==k-1) continue;
        dijkstra(i);
        ans=max(ans,dis[k-1]+dis1[i]);
    }
    printf("%d\n",ans);
}
正解:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define N 1000
#define inf 0x3fffffff
int m,n,k,dis1[N+1],dis[N+1],e[N+1][N+1];
bool vis[N+1];
void dijkstra(int x)
{
    memset(vis,false,sizeof(vis));
    for(int i=0;i<n;i++)
        dis[i]=e[x][i];
    for(int i=0;i<n-1;i++)
    {
        int tmp=inf,u=-1;
        for(int j=0;j<n;j++)
        {
            if(tmp>dis[j]&&!vis[j]&&dis[j])
            {
                tmp=dis[j];
                u=j;
            }
        }
        if(u==-1) break;
        vis[u]=true;
        for(int j=0;j<n;j++)
        {
            if(j==x) continue;
            if(!vis[j]&&e[u][j]&&(dis[j]>dis[u]+e[u][j]||!dis[j]))
                dis[j]=dis[u]+e[u][j];
        }
    }
}
int main()
{
    int a,b,c,ans=0;
    scanf("%d%d%d",&n,&m,&k);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        e[a-1][b-1]=c;
    }
    dijkstra(k-1);
    for(int i=0;i<n;i++)
        dis1[i]=dis[i];
    for(int i=0;i<n;i++)
        for(int j=i+1;j<n;j++)
            swap(e[i][j],e[j][i]);
    dijkstra(k-1);
    for(int i=0;i<n;i++)
        ans=max(ans,dis1[i]+dis[i]);
    printf("%d\n",ans);
}

利用 TensorFlow 训练自己的目标识别器。本文内容来自于我的毕业设计,基于 TensorFlow 1.15.0,其他 TensorFlow 版本运行可能存在问题。.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值