HDU - 5391(打表找规律)

19 篇文章 0 订阅
8 篇文章 0 订阅

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become n

times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
Input
The first line of input contains an integer T , representing the number of cases.

The following T lines, each line contains an integer n , according to the description.
T105,2n109

Output
For each test case, output an integer representing the answer.
Sample Input
2
3
10
Sample Output
2
0
题意:有一个球初始大小为1,在第n天的时候回变成第n-1天的n倍,问第n天的球的大小取余n是多少?

这题感觉无从下手,题目求的是第n天的球的大小取余n的值,但是我们只要打个表就会发现,这个值跟n有关,若n是素数,那么答案就是n-1,否则就是0。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<queue>
#include<map>
#include<vector>
#include<stack>
#define inf 0x3fffffff
using namespace std;
typedef long long LL;
const int N=1e9+1;
unsigned long long a[1000];
int main()
{
    //打表找规律
//    a[1]=1,a[2]=2;
//    for(int i=3;i<=21;i++)
//    {
//        a[i]=i*a[i-1];
//        printf("%llu %d %llu\n",a[i-1],i,a[i-1]%i);
//    }
    int t,n;
    bool flag;
    scanf("%d",&t);
    while(t--)
    {
        flag=true;
        scanf("%d",&n);
        if(n==2) printf("1\n");
        else if(n==3||n==4) printf("2\n");
        else
        {
            for(int i=2;i*i<=n;i++)
                if(n%i==0)
                {
                    printf("0\n");
                    flag=false;
                    break;
                }
            if(flag) printf("%d\n",n-1);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值