hdu 5979 Convex (简单数学&正余弦公式)

Convex

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1482    Accepted Submission(s): 990


Problem Description
We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex
 

Input
There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.
 

Output
For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.
 

Sample Input
 
 
4 190 90 90 906 160 60 60 60 60 60
 

Sample Output
 
 
2.0002.598
 

Source
 

Recommend
wange2014

昨晚的比赛,很简单的一道题,但是昨晚很无奈的是,把角度转换成弧度的时候除的是360?????弧度=角度*Pi/180;关于正余弦公式的运用可以看看这篇博客。那么再来回顾一下这道题目:题目给出一个多边形的顶点到中心点的距离(到中心点的都相等)以及多边形各个角的角度,要你求出多边形的面积。一开始我认为既然所有顶点到中心点的距离都相等,那么这个多边形就一定是正多边形了,但这样其实是错的,下图就很好的说明了这一点:

思路:我们可以将多边形化分成n(n是多边形的边数)个三角形,根据正余弦公式可以把每个三角形的面积求出来,然后在累加起来就是答案了。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<iostream>
#include<map>
#include<set>
#include<vector>
#include<stack>
#include<queue>
#define inf 0x3fffffff
using namespace std;
typedef long long LL;
const double eps=1e-6;
const double pi=acos(-1);
int main()
{
    int n,d;
    double a,ans;
    while(~scanf("%d%d",&n,&d))
    {
        ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lf",&a);
            ans+=d*d*sin(a*pi/180)/2;
        }
        printf("%.3f\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值