【PAT甲级 - C++题解】1061 Dating

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1061 Dating (pintia.cn)
🔑中文翻译:约会
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1061 Dating

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04
思路
  1. 这题第一个输出的是星期,由第一个字符串和第二个字符串中相同位置的第一个相等的大写字母来判断,该大写字母在字母表中从 A A A 开始排第几,输出的就是星期几。
  2. 第二个输出的是小时,由第一个字符串和第二个字符串中相同位置的第二个相等的合法字符来判断,该合法字符的范围在 0 ∽ 9 0\backsim9 09 ,且 10 10 10 以后的数用 A ∽ N A\backsim N AN 来代替。
  3. 第三个输出的是分钟,由第三个字符串和第四个字符串中相同位置的第一个相等的字母来判断,第几个位置相等就输出多少,注意是从 0 0 0 开始。
代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
    string wek[7] = { "MON","TUE","WED","THU","FRI","SAT","SUN" };
    string a, b;
    cin >> a >> b;
    
    //1.判断星期几
    int k = 0;
    while (1)
    {
        if (a[k] == b[k] && a[k] >= 'A' && a[k] <= 'G')    break;
        k++;
    }
    cout << wek[a[k] - 'A'] << " ";

    //2.判断多少小时
    k++;
    while (1)
    {
        if (a[k] == b[k] && (a[k] >= '0' && a[k] <= '9' || a[k] >= 'A' && a[k] <= 'N')) break;
        k++;
    }
    printf("%02d:", a[k] <= '9' ? a[k] - '0' : a[k] - 'A' + 10);

    //3.判断多少分钟
    k = 0;
    string c, d;
    cin >> c >> d;
    while (1)
    {
        if (c[k] == d[k] && (c[k] >= 'A' && c[k] <= 'Z' || c[k] >= 'a' && c[k] <= 'z'))
            break;
        k++;
    }
    printf("%02d\n", k);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值