【PAT甲级 - C++题解】1108 Finding Average

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1108 Finding Average (pintia.cn)
🔑中文翻译:求平均值
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1108 Finding Average

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
思路
  1. 可以利用异常处理的语法来判断数字是否合法,因为在调用 stof 函数(将字符串转换成浮点数类型)时,如果转换的是不合法数字,就会报异常。但是如果该字符串前面是数字后面不是数字,例如 12.2astof 就只会转换到第一个非法数字停止即将 12.2a 转换成 12.2 ,所以并不会报异常,这里还需要我们额外去判断,如果转换时没有用到字符串的所有元素也要标记为非法数字。
  2. 数字需要在 [-1000,1000] 的范围内,否则要标记为非法数字。
  3. 数字的精度不能超过 2 位,否则要标记为非法数字。
  4. 如果是合法数字则更新合法数字数量 cnt 以及合法数字总和 sum ,否则输出对应答案。
  5. 最终根据 cnt 的数量输出对应的答案。
代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    cin >> n;

    int cnt = 0;  //统计合法数字的个数
    double sum = 0;   //统计合法数字的总和
    for (int i = 0; i < n; i++)
    {
        string str;
        cin >> str;

        double x;
        bool success = true;	//判断是否为合法数字
        try
        {
            size_t idx; //用来取stof转换到第几个位置
            x = stof(str, &idx);
            //例如12.2a也是能够转换成12.2,但却是不合法的需额外判断
            if (idx < str.size())  success = false;
        }
        catch (...)  //...表示接受任何异常
        {
            success = false;
        }

        //数字需要在[-1000,1000]范围内
        if (x < -1000 || x>1000)   success = false;
        
        //小数点后面最多只能有2位
        int k = str.find('.');
        if (k != -1 && str.size() - k > 3)  success = false;

        if (success) cnt++, sum += x;
        else printf("ERROR: %s is not a legal number\n", str.c_str());
    }

    if (cnt == 0) puts("The average of 0 numbers is Undefined");
    else if (cnt == 1) printf("The average of 1 number is %.2f", sum);
    else    printf("The average of %d numbers is %.2f", cnt, sum / cnt);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值