【PAT甲级 - C++题解】1135 Is It A Red-Black Tree

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1066 Root of AVL Tree (pintia.cn)
🔑中文翻译:AVL树的根
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1135 Is It A Red-Black Tree

题目详情 - 1135 Is It A Red-Black Tree (pintia.cn)

1628. 判断红黑树 - AcWing题库

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

在这里插入图片描述在这里插入图片描述在这里插入图片描述
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No
题意

数据结构中有一类平衡的二叉搜索树,称为红黑树。

它具有以下 5 5 5 个属性:

  • 节点是红色或黑色。
  • 根节点是黑色。
  • 所有叶子都是黑色。(叶子是 NULL节点)
  • 每个红色节点的两个子节点都是黑色。
  • 从任一节点到其每个叶子的所有路径都包含相同数目的黑色节点。

例如,题目中给出的三个图,第一个是红黑树,后两个不是。

现在,对于每个给定的二叉搜索树,请你判断它是否是合法的红黑树。

注意:给定的前序遍历序列可能不合法,即无法构建出合法二叉搜索树。虽然与上述有点歧义,但是 PAT 中的数据就存在无法构建合法二叉搜索树的情况,需要额外去判断。

思路

这道题结合了之前通过前序数组构建二叉搜索树的题目,需要我们利用给定的前序数组,得到中序数组,因为二叉搜索树的中序遍历结果一定是有序的,然后再通过两个数组构建起二叉搜索树。

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-qUb9TOAc-1664757740214)(PAT 甲级辅导.assets/4.png)]

我们在构建二叉搜索树的同时再去判断是否合法:

  1. 是否会出现无法构建起二叉搜索树的情况,即中序数组与前序数组的根结点位置不合法。
  2. 左右子树中黑色结点的数量是否相等。
  3. 如果当前结点是红色结点,则其孩子结点是否都是黑色结点。

另外,要再构建完后判断根结点是否为黑色结点。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 40;
int pre[N], in[N];
unordered_map<int, int> pos;
bool ans;

int build(int il, int ir, int pl, int pr, int& sum)
{
    int root = pre[pl];   //找到根结点
    int k = pos[abs(root)];    //获得左子树的数量

    //可能会出现无法构建成二叉搜索树的情况
    if (k<il || k>ir)
    {
        ans = false;
        return 0;
    }

    int left = 0, right = 0, ls = 0, rs = 0;
    if (il < k)    left = build(il, k - 1, pl + 1, pl + 1 + k - il - 1, ls);
    if (ir > k)    right = build(k + 1, ir, pl + 1 + k - il - 1 + 1, pr, rs);

    if (ls != rs)  ans = false;  //左右子树黑色结点数量必须相等
    sum = ls; //更新当前结点子树中黑色结点的数量和

    if (root < 0)  //如果当前结点是红色结点
    {
        if (left < 0 || right < 0) ans = false;
    }
    else    sum++;  //如果当前结点是黑色结点

    return root;
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        int n;
        cin >> n;
        for (int i = 0; i < n; i++)
        {
            cin >> pre[i];
            in[i] = abs(pre[i]);
        }

        sort(in, in + n);  //获得中序遍历

        pos.clear();
        for (int i = 0; i < n; i++)  pos[in[i]] = i; //记录元素下标位置

        ans = true;
        int sum;
        int root = build(0, n - 1, 0, n - 1, sum);

        if (root < 0)  ans = false;  //根结点不能是红色结点
        if (ans) puts("Yes");
        else    puts("No");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值