【PAT甲级 - C++题解】1152 Google Recruitment

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1152 Google Recruitment (pintia.cn)
🔑中文翻译:谷歌的招聘
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1152 Google Recruitment

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
在这里插入图片描述

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404
题意

从任一给定的长度为 L 的数字中,找出最早出现的 K 位连续数字所组成的素数。

思路

由于题目的时间限制为 0.2 秒,如果直接用试除法每次都从前往后除以每个自然数,从而判断是否为质数可能会超时。所以我们可以将所有的质数先筛出来,然后再以长度为 k 的滑动窗口从前往后遍历字符串,用前面筛选出来的质数去判断当前窗口内的数字是否为质数。

代码
#include<bits/stdc++.h>
using namespace std;

const int M = 40000;
bool st[M];
int primes[M], cnt;

//先把10的9次方内的所有质数筛出来
void init()
{
    for (int i = 2; i < M; i++)
        if (!st[i])
        {
            primes[cnt++] = i;    //记录该质数
            //将i的倍数的所有数筛去
            for (int j = i * 2; j < M; j += i)
                st[j] = true;
        }
}

//用筛出来的所有质数去判断x是否为质数
bool check(int x)
{
    for (int i = 0; primes[i] <= x / primes[i]; i++)
        if (x % primes[i] == 0)
            return false;
    return true;
}

int main()
{
    init();

    int len, k;
    string str;
    cin >> len >> k >> str;

    //遍历字符串,判断是否能找到质数
    for (int i = 0; i <= len - k; i++)
    {
        //将字符串转换成整数
        int x = stoi(str.substr(i, k));
        //判断是否为质数
        if (check(x))
        {
            cout << str.substr(i, k);
            return 0;
        }
    }

    //如果没有找到质数则输出404
    puts("404");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值