【PAT甲级 - C++题解】1045 Favorite Color Stripe

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1045 Favorite Color Stripe (pintia.cn)
🔑中文翻译:最佳彩色带
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1045 Favorite Color Stripe

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7
题意

这道题就是最长公共子序列的变种题,给定 ab 两个字符串,找到 ab 中出现长度最长的子串,注意 a 中的字符是可以在 b 中重复出现的。

思路

状态表示: f [ i ] [ j ] f[i][j] f[i][j] 表示 p[1~i]s[1~j] 的所有公共子序列的集合中长度的最大值。

状态计算:

先从上一步转移过来: f [ i ] [ j ] = m a x ( f [ i − 1 ] [ j ] , f [ i ] [ j − 1 ] ) f[i][j] = max(f[i - 1][j], f[i][j - 1]) f[i][j]=max(f[i1][j],f[i][j1])

如果 s 中当前字符与 p 中当前字符匹配: f [ i ] [ j ] = m a x ( f [ i ] [ j ] , f [ i ] [ j − 1 ] + 1 ) f[i][j] = max(f[i][j], f[i][j - 1] + 1) f[i][j]=max(f[i][j],f[i][j1]+1)

这道题和原来的最长公共子序列不同之处在于后面这个更新,是 f [ i − 1 ] [ j − 1 ] + 1 f[i-1][j-1]+1 f[i1][j1]+1 ,但是这里因为 p 中的字符可以重复出现,所以就是 f [ i ] [ j − 1 ] + 1 f[i][j-1]+1 f[i][j1]+1

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 210, M = 10010;
int n, m, l;
int p[N], s[M], f[N][M];

int main()
{
    cin >> n >> m;
    for (int i = 1; i <= m; i++)   cin >> p[i];

    cin >> l;
    for (int i = 1; i <= l; i++)   cin >> s[i];

    for (int i = 1; i <= m; i++)
        for (int j = 1; j <= l; j++)
        {
            f[i][j] = max(f[i - 1][j], f[i][j - 1]);
            if (p[i] == s[j])  f[i][j] = max(f[i][j], f[i][j - 1] + 1);
        }

    cout << f[m][l] << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值