【PAT甲级 - C++题解】1101 Quick Sort

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1101 Quick Sort (pintia.cn)
🔑中文翻译:快速排序
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1101 Quick Sort

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5
题意

我们需要计算给定的数组的分界点数量,并输出出来,分界点的定义如下:

  1. 该数左边的所有值都要小于它。
  2. 该数右边的所有值都要大于它。
思路

我们可以先预处理出两个数组 lr ,分别表示每个数在其左半部分中的最大值以及每个数在其右半部分中的最小值。然后再从前往后遍历一遍,找出满足条件的分界点并放入答案数组 res 中,最后输出结果即可。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 100010, INF = 0x3f3f3f3f;
int a[N], l[N], r[N];
int n;

int main()
{
    //输入数组
    cin >> n;
    for (int i = 1; i <= n; i++)    cin >> a[i];

    //从左到右计算一遍每个数在其左半部分中的最大值
    for (int i = 1; i <= n; i++)   l[i] = max(a[i], l[i - 1]);
    //从右到左计算一遍每个数在其右半部分中的最小值
    r[n + 1] = INF;
    for (int i = n; i >= 1; i--)   r[i] = min(a[i], r[i + 1]);

    //判断分界点
    vector<int> res;
    for (int i = 1; i <= n; i++)
        if (a[i] > l[i - 1] && a[i] < r[i + 1])
            res.push_back(a[i]);

    //输出结果
    cout << res.size() << endl;
    if (res.size())
    {
        cout << res[0];
        for (int i = 1; i < res.size(); i++)   cout << " " << res[i];
    }
    cout << endl;

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值