【PAT甲级 - C++题解】1063 Set Similarity

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1063 Set Similarity (pintia.cn)
🔑中文翻译:集合相似度
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt×100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%
题意

给定若干集合,让我们计算询问的集合之间的相似度。

相似度计算公式为 N c / N t × 100 % N_c/N_t×100\% Nc/Nt×100% ,其中 N c N_c Nc 表示两个集合交集的元素个数,而 N t N_t Nt 表示两个集合并集的元素个数。

思路

我们可以先将所有集合存进容器当中,然后再分别计算询问的集合的相似度。 N c N_c Nc 可以遍历集合 a 中的元素,判断每个元素是否在集合 b 中从而计算出来。而 N t N_t Nt 可以用集合 a 的元素个数加上集合 b 的元素个数,再减去 N c N_c Nc 得到。

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-3IPXJeyf-1668248596877)(PAT 甲级辅导.assets/image-20221031163210877.png)]

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 110;
unordered_set<int> S[N];
int n, m;

int main()
{
    //输入每一个集合
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> m;
        while (m--)
        {
            int x;
            cin >> x;
            S[i].insert(x);
        }
    }

    //计算询问集合之间的相似度
    cin >> m;
    while (m--)
    {
        int a, b;
        cin >> a >> b;
        //计算两个集合交集元素的个数
        int nc = 0;
        for (auto& x : S[a])   nc += S[b].count(x);
        //计算两个集合并集元素的个数
        int nt = S[a].size() + S[b].size() - nc;
        //输出结果
        printf("%.1lf%%\n", (double)nc / nt * 100);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值