【PAT甲级 - C++题解】1145 Hashing - Average Search Time

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1145 Hashing - Average Search Time (pintia.cn)
🔑中文翻译:期终成绩
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1145 Hashing - Average Search Time

1638. 哈希 - 平均查找时间 - AcWing题库

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 105.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8
题意

这道题给定一个表的大小以及元素的个数,我们需要利用二次探测法来计算每个元素在表中的位置,如果无法插入则输出 %d cannot be inserted. 。然后再对给定的数值进行查询,并输出查找的平均时间。需要注意的是,如果无法找到一个数值,则该查找的时间为哈希表长 s1s+1

另外,表的大小必须为质数,如果给定的不是质数,则需要求出大于该值的最小质数当做表长。

关于什么是二次探测法,我在之前的 C++ 实现查找的博客中有详细讲解,传送门如下:

(239条消息) C++实现查找 - 顺序、二分和哈希查找_Pandaconda的博客-CSDN博客_顺序查找c++

思路

具体思路如下:

  1. 先确保哈希表长为质数,如果给定的表长不为质数,则找到大于给定表长的最小质数。
  2. 插入给定的数值,如果无法插入则输出对应语句。
  3. 查询给定的数值,最后输出平均查找时间。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
int s, n, m;
int h[N];

//判断x是否为质数
bool is_prime(int x)
{
    if (x == 1)    return false;
    for (int i = 2; i * i <= x; i++)
        if (x % i == 0)
            return false;
    return true;
}

//查找位置的同时计算查询的次数
int find(int x, int& cnt)
{
    int t = x % s;
    cnt = 1;
    for (int i = 0; i < s; i++, cnt++)
    {
        int k = (t + i * i) % s;
        if (!h[k] || h[k] == x)   return k;
    }
    return -1;
}

int main()
{
    cin >> s >> n >> m;

    //确保哈希表长度为质数
    while (!is_prime(s))  s++;

    //插入元素
    for (int i = 0; i < n; i++)
    {
        int x, count;
        cin >> x;
        int t = find(x, count);
        if (t == -1)   printf("%d cannot be inserted.\n", x);
        else    h[t] = x;
    }

    //查询元素
    int cnt = 0;
    for (int i = 0; i < m; i++)
    {
        int x, count;
        cin >> x;
        find(x, count);
        cnt += count;
    }

    //输出平均查找时间
    printf("%.1lf\n", (double)cnt / m);

    return 0;
}
  • 8
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值