【PAT甲级 - C++题解】1107 Social Clusters

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1107 Social Clusters (pintia.cn)
🔑中文翻译:社会集群
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1107 Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
题意

给定社交网络中所有人的兴趣爱好,请你找到所有社会群集。

输入第一行是人数 n ,接下来的 n 行输入编号从 1~n 所有人的爱好。

社会群集判断标准:只要两个人有共同爱好,就属于同一社会群集,比如编号为 35 的人有共同爱好,37 的人也有共同爱好,则 357 都属于同一社会群集。

思路

具体思路如下:

  1. 输入每个人的爱好,用一个数组 h 来存储每个爱好含有哪些人。
  2. 初始化并查集,然后将每个爱好中存储的人进行集合合并。
  3. 统计每个集合的人数并进行降序排序,然后统计集合的个数。
  4. 输出统计结果,注意行末不能有空格。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 1010;
int p[N], cnt[N];
vector<int> h[N];

//并查集查找模板
int find(int x)
{
    if (p[x] != x) p[x] = find(p[x]);
    return p[x];
}

int main()
{
    int n, k;
    cin >> n;

    //先整理每个爱好有哪些人
    for (int i = 0; i < n; i++)
    {
        scanf("%d:", &k);
        while (k--)
        {
            int x;
            cin >> x;
            h[x].push_back(i);
        }
    }

    //初始化并查集
    for (int i = 0; i < n; i++)    p[i] = i;

    //对每个爱好里的人进行集合合并
    for (int i = 1; i <= 1000; i++)
        for (int j = 1; j < h[i].size(); j++)
        {
            int a = h[i][0], b = h[i][j];
            a = find(a), b = find(b);
            p[a] = b;
        }

    //统计每个集合人数个数并进行降序排序
    for (int i = 0; i < n; i++)    cnt[find(i)]++;
    sort(cnt, cnt + n, greater<int>());

    //计算集合个数
    int res = 0;
    while (cnt[res]) res++;

    //输出统计结果
    cout << res << endl << cnt[0];
    for (int i = 1; i < res; i++)  cout << " " << cnt[i];
    cout << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值