【PAT甲级 - C++题解】1109 Group Photo

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1109 Group Photo (pintia.cn)
🔑中文翻译:合影
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1109 Group Photo

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤104), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation – that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John
题意

给定 N 个人的名字及身高,现在要求将这 N 个人排成 K 行,规则如下:

  • 每行的人数必须为 N/K(向下取整),所有多余的人(如果有)都放到最后一行;
  • 位于后排的所有人都不得矮于位于前排的任何人;
  • 在每一行中,最高的人站在该行的中心位置(定义为位置 m/2+1 ,位置从 1 开始编号,其中 m 是该行的总人数,除法结果向下取整);
  • 在每一行中,其他人必须按照其身高非递增顺序依次排入该行,交替地将他们的位置先安排到最高人的右侧,然后再安排到最高人的左侧(例如,假设五个人的身高为 190、188,186、175、170 ,最终阵型将是 175、188、190、186、170 。在这里,我们假设你面对着合影人员,因此你的左手边位置其实是最高人的右手边位置。);
  • 当许多人的身高相同时,必须按姓名的字典序升序进行排序,保证所有人的姓名不重复。
思路

具体思路如下:

  1. 定义一个结构体数组来存储每个人的信息,输入完信息后需要进行排序,按照每个人的身高降序排序,如果身高相同则按照名字字典序升序排序。
  2. 从最后一排往前安排队伍,即最后一排身高都要比前面人高,刚排完序的数组就派上用场了。用一个临时数组 line 来保存当前行的排队情况,用双指针从中间往两边排,因为题目要求是排好中间的最高人后,交替的将其他人先排最高人的右侧,再排最高人的左侧,所以我们需要先排右指针指向的人,再排左指针指向的人。
  3. 输出当前行排队情况,注意末尾不能有空格。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
int n, k;

//存储每个人的信息
struct Person
{
    string name;
    int height;

    bool operator<(const Person& t)const
    {
        //按身高降序排序,身高相等则按名字字典序升序排序
        if (height != t.height)    return height > t.height;
        return name < t.name;
    }
}p[N];
string line[N];

int main()
{
    cin >> n >> k;

    //输入每个人的信息并排序
    for (int i = 0; i < n; i++)    cin >> p[i].name >> p[i].height;
    sort(p, p + n);

    //开始排队
    for (int i = 0, j = 0; i < k; i++)
    {
        int len = n / k;
        if (!i)  len += n % k;    //特判最后一排
        //利用双指针从中间开始往两边排人
        for (int r = len / 2 + 1, l = r - 1; l > 0 || r <= len; l--, r++)
        {
            //先排右边再排左边
            if (r <= len)    line[r] = p[j++].name;
            if (l > 0)    line[l] = p[j++].name;
        }

        //输出排好的这一行
        cout << line[1];
        for (int u = 2; u <= len; u++)
            cout << " " << line[u];
        cout << endl;
    }

    return 0;
}
  • 11
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 10
    评论
评论 10
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值