【PAT甲级 - C++题解】1128 N Queens Puzzle

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1128 N Queens Puzzle (pintia.cn)
🔑中文翻译:皇后问题
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1128 N Queens Puzzle

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1,Q2,⋯,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

在这里插入图片描述在这里插入图片描述
Figure 1Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format “N Q1 Q2 … QN”, where 4≤N≤1000 and it is guaranteed that 1≤QiN for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES
题意

给定 N 组数据,每组数据代表一个棋盘上皇后的分布情况,需要我们判断每个棋盘是否满足八皇后问题,即同一行、同一列和对角巷上不能同时存在两个及以上的皇后。

这样我们就可以用一个整数序列 Q1,Q2,…,QN 来表示一种棋盘摆放,其中 Qi 表示第 i 列的皇后所在的行号。

例如,图1的棋盘摆放可以用 (4, 6, 8, 2, 7, 1, 3, 5) 来表示,它是解决八皇后问题的一种合理摆放方案。

图2的棋盘摆放可以用 (4, 6, 7, 2, 8, 1, 9, 5, 3) 来表示,它并不是解决九皇后问题的一种合理摆放方案。

思路

我们可以通过三个数组来表示每一行,及正对角线上和反对角线上是否出现冲突情况。因为题目是按照每一列皇后给出的,所以不用判断每一列上是否同时存在皇后。

而每一行的判断方法就是每当传入一个皇后行的坐标,就将对应位置置为 1 ,如果已经为 1 ,则说明有冲突。

通过观察可以发现,在正对角线上的所有点的横坐标 x 与纵坐标 y 之和即 x+y 的值都相等,所以可以采用上面的方法进行冲突判断。

而在反对角线上的所有点的横坐标 x 与纵坐标 y 之差的值相等,但是可能会出现负数,无法用数组下标表示,所以还需要加上一个偏移量 n 使之变成正数再继续判断。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 1010;
bool row[N], dg[N * 2], udg[N * 2];	//对角线需要2*N

int main()
{
    int n;
    cin >> n;

    //判断每一组数据
    for (int i = 0; i < n; i++)
    {
        //初始化数组
        memset(row, 0, sizeof row);
        memset(dg, 0, sizeof dg);
        memset(udg, 0, sizeof udg);

        //检验冲突
        int m;
        cin >> m;
        bool success = true;
        for (int y = 1; y <= m; y++)
        {
            int x;
            cin >> x;
            //判断是否有冲突
            if (row[x] || dg[x + y] || udg[y - x + m]) success = false;
            row[x] = dg[x + y] = udg[y - x + m] = true;
        }

        //输出判断结果
        if (success) puts("YES");
        else puts("NO");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值