uva 10167--birthday cake

Background

Lucy and Lily are twins. Today is their birthday. Mother buys a birthday cake for them.Now we put the cake onto a Descartes coordinate. Its center is at (0,0), and the cake's length of radius is 100.

There are 2N (N is a integer, 1<=N<=50) cherries on the cake. Mother wants to cut the cake into two halves with a knife (of course a beeline). The twins would like to be treated fairly, that means, the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). Can you help her?

Note: the coordinate of a cherry (x , y) are two integers. You must give the line as form two integers A,B(stands for Ax+By=0), each number in the range [-500,500]. Cherries are not allowed lying on the beeline. For each dataset there is at least one solution.

Input

The input file contains several scenarios. Each of them consists of 2 parts: The first part consists of a line with a number N, the second part consists of 2N lines, each line has two number, meaning (x,y) .There is only one space between two border numbers. The input file is ended with N=0.

Output

For each scenario, print a line containing two numbers A and B. There should be a space between them. If there are many solutions, you can only print one of them.

Sample Input

2
-20 20
-30 20
-10 -50
10 -5
0

Sample Output

0 1
 
此题就是简单的遍历所有可能直线直到找到满足条件的为止,诶比较郁闷的就是开始居然用了/产生了不精确性,这一点的注意一下了,一般/要化成乘法运算,这样避免不必要的精确性问题,好了直接贴代码了:
#include<stdio.h>
#include<stdlib.h>
int a,b,n;
struct coor{
   int x;
   int y;
}c[105];
bool check(int A,int B){
    int num=0;
    for(int i=0;i<2*n;i++){
        if(A*c[i].x+B*c[i].y==0)return false;      
        if(A*c[i].x+B*c[i].y>0)num++;
    }
    if(num==n){
       a=A,b=B;
       return true;
    }
    return false;
}
int main(){
    bool flag;
    while(scanf("%d",&n)==1&&n){
        flag=true;
        for(int i=0;i<2*n;i++)
             scanf("%d %d",&c[i].x,&c[i].y);
        for(int i=-500;i<=500&&flag;i++){
            for(int j=-500;j<=500&&flag;j++){
            	if(i<0&&j<0)continue;
                if(check(i,j))
                    flag=false;
            }
        }
        printf("%d %d\n",a,b);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值