HDU 1598 find the most comfortable road (暴力+kruskal)

Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure—超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

Input
输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1< n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

Sample Input
4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2

Sample Output
1
0

//#define Night_13
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
int n, m, root[201];

class road {
public:
    int s, e, spd;
    friend bool operator < (road a, road b) {
        return a.spd < b.spd;
    }
} r[1100];

void Init() {
    for (int i = 0; i < 201; ++i) {
        root[i] = i;
    }
}

int Find(int x) {
    int fx = x;
    while (root[fx] != fx) {
        fx = root[fx];
    }
    int i = x, j;
    while (root[i] != fx) {
        j = root[i];
        root[i] = fx;
        i = j;
    }
    return fx;
}

void Union(int a, int b) {
    int fa = Find(a), fb = Find(b);
    if (fa != fb) {
        root[fb] = fa;
    }
}

int main() {

#ifdef Night_13
    freopen("input.txt", "r", stdin);
#endif
    while (scanf("%d%d%*c", &n, &m) != EOF) {
        for (int i = 0; i < m; ++i) {
            scanf("%d%d%d", &r[i].s, &r[i].e, &r[i].spd);
        }
        sort(r, r + m);
        int cases;
        scanf("%d", &cases);
        while (cases--) {
            int a, b, ans = INF;
            scanf("%d%d", &a, &b);
            for (int i = 0; i < m; ++i) {
                Init();
                for (int j = i; j < m; ++j) {
                    Union(r[j].s, r[j].e);
                    if (Find(a) == Find(b)) {
                        ans = min(ans, r[j].spd - r[i].spd);
                        break;
                    }
                }
            }
            if (ans == INF) printf("-1\n");
            else printf("%d\n", ans);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值